Doesn't work with RealSense D435

Until now, I used orbbec and realsense arrived finally in this morning.
I started nuitrack unity project but it doesn’t work.
I installed realsense driver and orbbec still works good but realsense doesn’t work.
What I forgot?
Thanks in advance.

This may mess with your head - BUT - if you install the Intel Universal Windows Platform driver - then its likely that Nuitrack wont actually be able see your device.

The nuitrack system utilises the Intel Realsense SDK which has its own method of connecting to the Realsense sensors - and that system does not utilize the UWP drivers.

The UWP driver is a general-purpose driver for UWP compatibility and is not specially written for the RealSense cameras. So use of UWP with the SDK is not a guaranteed under windows. As such I would suggest that you completely remove the UWP version of the drivers and stick with the native windows drivers.


Please follow the instructions below to achieve this:

Open Device Manager
Expand Imaging Devices
Right click on each entry for Intel RealSense 430 with RGB Module and…

Select “Uninstall this device.”

In the Uninstall Device dialog box, check the box for “Delete the driver software for this device” (this option will not be available for the second device) and click Uninstall.
Unplug and re-plug in the camera.
Verify that the uninstallation worked…

Check that the entries for the D435 in Device Manager are now under Cameras

Right click on each device, select Properties, Manufacturer should be listed as Microsoft.

NOTE: you may need to reboot to clean up drivers - but not always


Once you have completed this step - download the latest intel SDK or at a minimum the latest realsense viewer.

Run this an verify that it can connect and see the D435 sensor in its list of devices.
Next verify that the connection detected by the D435 is being reported as USB 3.0 or USB 3.1
Next open the Depth section of the realsense viewer and verify that you can select the 848x480 depth mode.
Now run the depth sensor from the viewer - and verify that you can see the 848x480 stream displaying.
Turn of the depth sensor off in the viewer

Next you should run the c11 example from the nuitrack/bin folder and verify that it also display the depth

Once you have all this test - THEN I would start looking at the UNITY examples.


1 Like

Thank you!
I removed driver and rebooted my computer.
So, realsense connected correctly.

Next, download viewer but it doesn’t work sadly.

c11 example same too.

Additionally, my windows camera app doesn’t work too.
And viewer detects camera of astra pro :frowning:

OK - you cant have the astra and the realsense devices connected at the same time.
Nuitrack is a one device only system - and it will always connect to a orbbec before it connects to realsense.

Disconnect every device connected to you computer - and go into your device manager and disable an internal camera on the system as well.

THEN - reboot your computer with no devices connected.

And work on getting the d435 running with the realsense viewer - it will never work on anything else if the viewer cant see it.


I didn’t find solution.
I reinstalled UWP driver with mind to give up.
It works…
I don’t know when it will make problem, it works now.
Thanks to Westa.