Unity3D closes instanly while open up the project and on play


Unity keeps closing itself without showing a crashing window when I try to play any sample scene in Nuitrack SDK. Sometimes the self-closing happens while the project is opening up.

  • OS: x64 Windows 10 Home
  • Nuitrack Runtime: 0.35.12
  • Nuitrack License: Trial License
  • Unity Editor: 2020.3.25f1
  • Sensor: Orbbec Astra Pro

Nuitrack is installed in the “Program Files” folder, and Unity Editor is run as admin. None of the other unity packages was imported.

I have tried two scenes, “AllModulesScene” in “NuitrackDemos” and “PointCloud” in “Tutorials/Point Cloud”. After I pressed the “Play” button, there was some kind of progress bar. And Unity closed itself when it reached the “Application.EnterPlayMode” step.

Sometimes it was closed while opening up the project.

No Unity crash window showed up.

Thank you in advance for your help.

Hello @Sean

We tested and failed to detect the problem. Send us the editor’s log https://docs.unity3d.com/Manual/LogFiles.html

And try running the test sample several times:
Program Files\Nuitrack\nuitrack\nuitrack\bin\nuitrack_sample.exe

Hello @Stepan.Reuk,

It said txt file is not supported for uploading, so I shared it from my Dropbox. Please check it at https://www.dropbox.com/s/va7qu1sxdhl1dwe/Editor%281%29.log?dl=0

I tried several times to run the test sample, but it was never successful. In the console, it displayed follow messages and then quit.

Create DepthProvider: AstraProPerseeDepthProvider
Access is denied.
terminate called after throwing an instance of 'boost::interprocess::interprocess_exception'
what (): Access is denied.

Have you installed Nuitrack as an administrator? If not or not sure, try reinstalling as an administrator

Hi @Stepan.Reuk ,

I uninstalled Nuitrack and ran install wizard as admin to install Nuitrack. But the issue is still there.


  1. Try run nuitrack_sample.exe as an administrator
  2. Make sure that no other software is using the camera at the time of launch


Running the test sample worked if it’s open as admin. I got a window displaying the depth output, and after one or two second it was forzen. On the top-left conrer there is also a line of text, “Please get a license at nuitrack.com”.

Activate the license (Nuitrack\nuitrack\nuitrack\activation_tool\Nuitrack.exe)
Try to grant full access rights to the Nuitrack folder to “all” users
Do it:Unity3D closes instanly while open up the project and on play
And check how it works in Unity now

The test scene can now be played without any problem, thank you for all your help!!

1 Like

But when I played the point cloud scene in the tutorial folder, it happened again. So, I re-opened Unity and played the scene again, now it worked. It seems to be not so stable.

So I tested it several times to play some scenes in Unity, and it will still quit on different time spots, such as:

  1. While opening up Unity
  2. While trying to play the first scene after I opened up Unity
  3. After I stopped a scene from playing, and clicked on the play button of another scene

try running the test sample several times:
Program Files\Nuitrack\nuitrack\nuitrack\bin\nuitrack_sample.exe

Do I understand correctly that you have restarted this sample several times? Try to test this sample longer. Make sure RGB and Depth are working fine (click on the image to switch modes)

Sorry for confusing you, what I meant in my previous reply is the “AllModulesScene” in the Nuitrack unity package. For the executable sample called “nuitrack_sample.exe”, I have just tried it as well, and it kept running through the entire 3 min without any issue (for trial license). So, the problem only happens in Unity Editor.

Can someone still help me with this issue?

I think I found the reason for this issue: the extension cable.

I was using an extension USB cable to connect my sensor with the PC and the issue happened a lot. Today I tried to connect the sensor directly to the PC, and everything worked properly without any issue.

I hope this can help someone who having the same problem as me.

1 Like

Sadly, I found out this is not the real reason / the only reason that caused the issue. However, I encountered a real “crash” which means I now have the crash report from Unity. So I decided to start a new topic for help. Here is the link to the new topic.