Android app crashes

What happened is that I opened an app that i developed With skeletal tracking a few months ago and it worked correctly but now it breaks and doesn’t start. I did the test With the VicoVR app and everything is fine but my app quits, any ideas?

Please advise:

  1. Did you update the Android version or change the device?
  2. Did you update the VicoVR version?
  3. Send us the logs (please use adb)

I updated to android version 10 and VicoVR version: 1.8.0

I want to tell you what I have been testing.

I updated the version of all the apps and also the unity package. But now when I opened the VicoVr app I couldn’t see anything when selecting the test sensor option, only the black screen.

Then I tried to uninstall the VicoVr app and opened my app and this time it did not close but, since I don’t have the VicoVR app I can’t connect the sensor.

Hi Said,

sorry for the issues you’ve encountered!

VicoVR is a 64-bit application for 64-bit devices now (since version 1.8.0, latest available version is 1.9.0). It’s necessary to add ARM64 platform support to your Android app. Please download latest version of Nuitrack SDK and update VicoVR to 1.9.0.
Next steps for Unity project are:

  • import new version of NuitrackSDK.unitypackage
  • select Assets\NuitrackSDK\Nuitrack\NuitrackAssembly\IL2CPP\ assembly
  • change Scripting Backend to IL2CPP in Player Settings (refer to Other Settings -> Configuration)
  • enable ARM64 in Target Architectures

Let me know if you have issues or questions.