Build Nuitrack SDK examples on Ubuntu 18.04

When I tried to build the examples of Nuitrack SDK on Ubuntu 18.04, I could not build them as follows;
(To do this, I just clone
Before following procedure, I installed opencv(3.4.9) from source code.
(Because, the version of libopencv-dev installing by apt is different from the required version of and

cd <NUITRACK_SDK_DIR>/Examples/nuitrack_console_sample
mkdir build
cd build
cmake …

<NUITRACK_SDK_DIR>/Examples/nuitrack_console_sample/…/…/Nuitrack/lib/linux64/ undefined reference to ZipArchive::GetEntriesCount() const' <NUITRACK_SDK_DIR>/Examples/nuitrack_console_sample/../../Nuitrack/lib/linux64/ undefined reference to ZipFile::ExtractFile(std::string const&, std::string const&, std::string const&)’
<NUITRACK_SDK_DIR>/Examples/nuitrack_console_sample/…/…/Nuitrack/lib/linux64/ undefined reference to ZipArchive::GetEntry(int)' <NUITRACK_SDK_DIR>/Examples/nuitrack_console_sample/../../Nuitrack/lib/linux64/ undefined reference to ZipArchiveEntry::GetFullName() const’
<NUITRACK_SDK_DIR>/Examples/nuitrack_console_sample/…/…/Nuitrack/lib/linux64/ undefined reference to `ZipFile::Open(std::string const&)’
collect2: error: ld returned 1 exit status
CMakeFiles/nuitrack_console_sample.dir/build.make:94: recipe for target ‘nuitrack_console_sample’ failed
make[2]: *** [nuitrack_console_sample] Error 1
CMakeFiles/Makefile2:67: recipe for target ‘CMakeFiles/nuitrack_console_sample.dir/all’ failed
make[1]: *** [CMakeFiles/nuitrack_console_sample.dir/all] Error 2
Makefile:83: recipe for target ‘all’ failed
make: *** [all] Error 2

How can I solve this problem?

I solve the problems. It’s just installation problem…

Hi, I’m having the exact same issue. Can you give more details on how you solved the “installation problem”?

I’m really sorry, I forgot how to solve the problem, because it was a little bit ago.

Hi @d0m3

Please check environment variables NUITRACK_HOME should be set to /usr/etc/nuitrack/ and LD_LIBRARY_PATH should be set to /usr/local/lib/nuitrack.
If they aren’t, rebooting your PC after Nuitrack installation should set them up.
Also you can try deleting libzip from your PC as it can conflict with Nuitrack version of libzip

Hi @d0m3

Has your issue been sloved?

@a.bragin Yes, it has been solved by:

  • Installation of nuitrack-ubuntu-amd64.deb
  • Setting “ProxyUrl” to our company Proxy in /usr/etc/nuitrack/data/nuitrack.config