Camera does not open


I want to use Nuitrack with a camera Intel Real Sense D415. The same camera (with the same cable works in other laptops). However, Nuitrack does not work in the one that I am trying it now. It detects the camera, but when running the Test, the black screen appears ready to start to capture (red lights of the camera open, but it does not start to capture any data). I am running:
Windows 10 at 64 bits, Intel Core i5-1035G1 CPU @1.00 Ghz 1.19 GHz, 8 GB RAM

The RGB camera of Real Sense D415 works fine as a webcam (within the “Camera” Windows app).
I tried the following:

  • I installed the latest versions of IntelRealSense SDK (I tried it with the latest 2 versions), however, both depth and RGB cameras were not working (although they are detected as connected to a USB 3.2). The error was related to: “USB SCP overflow”.
  • Intel Real Sense Viewer version 2.9 worked well (both depth camera and RGB camera) in the same laptop and same USB port.
  • I tried the latest version of Nuitrack and also v0.35.4 (the oldest version in github with the executable), however, they do not work (same result, it detects the camera, but it does not start to capture).

It seems weird. Do you have any idea how to solve it?

Thank you very much.

Best regards,

Gil Serrancolí

Hi @gilserrancoli,

You can try this: open nuitrack.config from %NUITRACK_HOME%/data and set the Realsense2Module.DeviceHardwareReset parameter to true.

Looking forward to your response.

Hi Vadim,

Thanks for the answer. However, it does not solve the issue. I also reboot the PC after this change. I also open nuitrack with administrator rights and without, but it is the same.
I attach the image of the black screen in this message.

Do you know what could it be the issue?



Could you please provide the following information:

  • driver version installed for Realsense cameras in your system where RealSense Viewer is working correctly (refer to Windows Device Manager)
  • is camera access granted for Windows apps (refer to Settings → Privacy → Camera and turn on “Allow apps to access your camera”)?

Also, you can try to reduce resolution for RGB and Depth here (nuitrack.config):


Thanks for the quick reply. I attach pictures of the drivers for Real Sense, the camera privacy settings (which seems okay), and the .config files in …/data.
I tried to decrease the resolution to the half: 320x240, but the result is the same.

I copy here what I obtain in the command window when running nuitrack_sample.exe:

Realsense2DepthProvider: device was removed!
Realsense2DepthProvider: device was added!
Create DepthProvider: Realsense2DepthProvider
NuitrackException (TerminateException): Realsense2DepthProvider: rs2_pipeline_wait_for_frames(pipe:000000000B26C1D0):

  • Frame didn’t arrive within 15000*
    terminate called after throwing an instance of ‘std::runtime_error’
  • what(): NuitrackException (TerminateException): Realsense2DepthProvider: rs2_pipeline_wait_for_frames(pipe:000000000B26C1D0):*
  • Frame didn’t arrive within 15000*

Hopefully this helps to identify what is happening.



@gilserrancoli, try to pause your antivirus software. This is likely blocking access to the sensor for Nuitrack. In this case, you can add Nuitrack to the antivirus exceptions.


This was the issue. When I stopped Kaspersky, the camera worked fine.

Thanks a lot!