Cannot find -lglut32


#1

Hi,
I’m trying to compile the example of the SDK NuitrackSDK/Examples/nuitrack_gl_sample, but it says I don’t have the glut library, so I tried to install freeglut with this link https://www.transmissionzero.co.uk/software/freeglut-devel/
I followed the installation instruction but I still get the same error cannot find -lglut32.

When I’m in the nuitrack_gl_sample here is the command I type:
mkdir build
cd build
cmake.exe -G “MinGW Makefiles” -DCMAKE_SH=“CMAKE_SH-NOTFOUND” …
mingw32-make.exe
It’s whith the last command that I get the error


#2

Please follow the steps from README.txt: <path_to_NuitrackSDK_folder>/Examples/nuitrack_gl_sample/README.txt
To install the glut library, follow the instructions below:

Please download glut.zip archive with 64-bit versions of libraries and follow the steps below:

    Install header files:

    copy \Include\gl folder to "C:\Program Files (x86)\Windows Kits\10\Include\10.0.16299.0\um" (note that 10.0.16299.0 is Windows 10 SDK version, it can differ for your system)

    Install export libraries:

    copy \Lib\x86\glut32.lib to "C:\Program Files (x86)\Windows Kits\10\Lib\10.0.16299.0\um\x86"
    copy \Lib\x64\glut32.lib to "C:\Program Files (x86)\Windows Kits\10\Lib\10.0.16299.0\um\x64"

    Install dynamic libraries:

    copy \bin\x86\glut32.dll to C:\Windows\System32
    copy \bin\x64\glut32.dll to C:\Windows\SysWOW64

If you’re using x64 compiler, you have to use "C:/Program Files/OpenNI/Lib64/openNI64.lib",
If you’re using x32 compiler, you have to use "C:/Program Files(x86)/OpenNI/Lib/openNI.lib".

#3

hi,
Thank you for your reply, it works with your version of glut! But you 've made a mistake :
32 bit dll go in sysWOW64 and 64 bit dll go in System32.

copy \bin\x86\glut32.dll to C:\Windows\SysWOW64
copy \bin\x64\glut32.dll to C:\Windows\System32

Regards