Can't get the Unity Tutorials Work: Can't create DepthSensor module


I’ve been trying to try out the Unity Tutorials examples, but none works for me for some reason.

I’m using Win10 + Kinect 2. I’ve downloaded the Nuitrack, and the Nuitrack samples all work for me.

However, when I try the tutorial project, I’m getting the following error (and others, but this seems to be the main issue here):

ModuleNotInitializedException: NuitrackException (ModuleNotInitializedException): Can’t create DepthSensor module
AstraProPerseeDepthProvider: Can’t create RGB Stream (VideoCapture device ID is not valid)
OpenNI2DepthProvider: Can’t open device ( DeviceOpen using default: no devices found
OpenNIDepthProvider: Can’t create OpenNI DepthGenerator (OpenNI Status: Can’t create any node of the requested type!)
Realsense2DepthProvider: Can’t enumerate Realsense2 camera

nuitrack.NativeImporter.throwException (nuitrack.NativeImporter+ExceptionType type, System.String message) (at :0)
nuitrack.NativeDepthSensor…ctor () (at :0)
nuitrack.DepthSensor.Create () (at :0)
NuitrackManager.NuitrackInit () (at Assets/NuitrackSDK/Nuitrack/Scripts/NuitrackManager.cs:225)
NuitrackManager.Awake () (at Assets/NuitrackSDK/Nuitrack/Scripts/NuitrackManager.cs:119)

The only thing I’ve changed in the config file is the Depth2ColorRegistration, which is now set to true. I notice that the CameraID in the config files is set to -1, which is kind of weird. I tried 0 and 1, but neither worked either. Please help. Thanks.

Hi ysysys,

  1. Please run one of our standard samples (for example, nuitrack_c11_sample.exe or nuitrack_sample.exe) and provide us with the console output.
  2. What is your Nuitrack runtime version? It’s displayed at the bottom of the Nuitrack activation tool (Nuitrack.exe).
  3. Please send us the value of your NUITRACK_HOME environment variable.

We are having the same issue with the latest Nuitrack SDK v0.35.12 on a Windows 10 system and a Kinect v2 camera connected.

The AllModulesScene (and every other tutorial scene) from the imported package in Unity 2020.3.24 throw these errors:

The activation tool, the samples and even our own skeleton tracking application is running fine with the new Nuitrack SDK and runtime dll. Its only the project with the Unity package from you that behaves wierd. It seams to enable and disable the Kinect camera several times when pressing play for the first time and hangs the Unity editor during this time. After a few seconds the camera is off and the error with the DepthSensor module appears in the log.

  1. Output for nuitrack_c11_sample and nuitrack_sample (was always like this without further issues)
    Start nuitrack c11
    Create DepthProvider: OpenNI2DepthProvider
    Can’t change mirror HW property for Depth stream ( Stream setProperty(7) failed
    Can’t change mirror HW property for RGB stream ( Stream setProperty(7) failed
  2. v0.35.12
  3. C:\Program Files\Nuitrack\nuitrack\nuitrack

Hello @dev_retrobrain
Can you send Unity editor.log file?

Sure, these are the steps that were done and should be reflected by the Editor log (had to convert it from log to xml unfortunalty, otherwise the upload is not allowed):
EditorUnity.xml (36.4 KB)

  1. made sure that nuitrack activation tool and samples were running fine (often the camera is not found until re-plugged to usb)

  2. closed all applications

  3. opened the unity project:

  • kinect camera lights turned on and off 3 times
  • according to the logs “Test Nuitrack init failed!” and “System.ArgumentOutOfRangeExpection”
  1. pressed play in the editor:
  • camera does not start at all
  • logs “Test Nuitrack (ver.3512) init was successful” but “Can’t create DepthSensor module” (see screenshot from post above)

Have you tried installing another skeleton tracking before (cubemos or some other)?
If so, then try:

  • delete them all.
  • Also check if there are no relevant environment variables left, delete them too.
  • Restart your PC
  • Try testing AllModulesScene again

Yes, I had Cubemos installed and already followed the instructions from here (otherwise Nuitrack did not open at all): HELP with 'Entry Point Not Found' dynamic link library libcnn-hpe.dll when I open the activation_tool

Just to be sure I completly deinstalled Cubemos now and checked that the environment variables were also gone (thank god their uninstaller is just running fine), restarted my PC, opened the Unity project with the Nuitrack package and… same behaviour!! The camera starts 6 times during the editor loading, then when pressing play on the AllModuleScenes for the first time it tries to start again once (but disables itself immediatly). Error messages same as described above.

Did you have a chance to look into the EditorUnity log? Where did you get the hint from it could be related to some other tracking SDKs? What else do I need to uninstall in order to get Nuitrack providing some valuable feedback whats wrong? The Kinect SDK?

Exact same problem here.
Unity 2020.3.27f1
Cubemos installed then deleted. Nuitrack deleted and reinstalled after.
Kinect SDK v2.0_1409 & Kinect v2 for XboxOne
nuitrack_sample.exe is working.
Unity Log:
Test Nuitrack (ver.3512) init was successful!
Current Scripting Backend Mono2x Target:Standalone
Sensor not connected
Can’t create DepthSensor module. Sensor connected? Is the connection stable? Are the wires okay?

This morning, my first and second tries were successful.
During my second try, I reached the 3 minutes time limit of the trial and then the error messages were back again at restarting the scene.
Can it be related?

EDIT - Restarting Unity does nothing.
Restarting PC works once on 2 tries.

Hi @boubouk50,

I see that nuitrack_sample is working. Have you tried running the sample several times?
Can you send Unity editor.log file?

Hi @irakli,

Yes nuitrack_sample is always working correctly, the Kinect V2 is starting and running each time.
In Unity, when the error occurs, the Kinect is not even starting.

Editor.xml (77.8 KB)

  • EDIT - Tried with 2.2.1811 and 2.0.1409 drivers with no better result.


  • When errors occur:
    Get device list error:
    Can’t enumerate devices: AstraProPerseeDepthProvider: Can’t open device ()
    Can’t enumerate devices: AzureKinectDepthProvider: No devices detected
    Can’t enumerate devices: OpenNI2DepthProvider: Can’t open device ()
    Can’t enumerate devices: Realsense2DepthProvider: Can’t enumerate Realsense2 camera
  • When it works:
    Device 0 [Sensor Name: Kinect v2, License: TRIAL]
    Create DepthProvider: OpenNI2DepthProvider

Same errors in Build (Standalone Win10).
At first try, it worked, then the same error occurred repeatedly.
Is there some info that are cached?

Hi @boubouk50,
Do you have any programs in the background that can use Keenetic v2?

I don’t think so.
I start Windows, open the unity project and the error occurs directly.
I found these services:

  • KinectMonitor
  • KinectService
  • KStudioHostService

I killed them but error still occurs. Can’t be sure about other programs.