Compatibility test not completing

Hi there,

I have been using Nuitrack for a while, but I recently had to reinstall the program on my computer. I keep running into the problem of the compatibility test not completing. It remains on this screen (I’ve had it running for about 20 minutes now) -

I’m using an Intel D435 camera on Windows 10.

Any ideas of what’s causing this?


Please run nuitrack_sample and provide us with the output (press “Win” + “R” -> type “cmd” -> type “nuitrack_sample”).

Hello! I’m having the same problem here with the same setup (Windows 10 and D435), the activation tool says “Error: Sample crashed. Exit code: -1073741819” and I can’t enter my activation key.
Here’s the output of the sample:

The device is working with the RealSenseViewer.

Thanks for your help!

Hi, I am having the same error code but with a different configuration. I’m using an Orbbec Astra on Windows 7. My camera is already activated but Unity kept crashing so I went to the activation tool to find an error code. The camera is working fine with other viewers, just not Nuitrack.

“Error: Sample crashed. Exit code: -1073741819”

When I run the samples from the command prompt it doesn’t output any info, but I found this on the details when crashing.

Problem signature:
Problem Event Name: APPCRASH
Application Name: nuitrack_sample.exe
Application Version:
Application Timestamp: 5d5e7e30
Fault Module Name: libopencv_videoio.dll
Fault Module Version:
Fault Module Timestamp: 5cecf446
Exception Code: c0000005
Exception Offset: 0000000000021cca
OS Version: 6.1.7601.
Locale ID: 1033
Additional Information 1: f961
Additional Information 2: f961207fca4333ddb0c6e2e1b8dc1161
Additional Information 3: 881d
Additional Information 4: 881d5c6379236c842356c401fafa2d11

It was working fine a few hours ago, the only thing I can think of that happened between it working this afternoon and now, is I plugged another Astra in to test a different app that is using the OrbbecSDK. I unplugged the other camera and loaded up my Nuitrack project and now I only get crashes.

Any advice or ways to generate more data for you to figure out whats going on is appreciated. I’ll also submit a support ticket.

Sorry to double post, but I just figured out what my issue was. Maybe this will help someone else.

Before I started having this issue, I needed to manually change the nuitrack.config file so my Color stream would work. (Referenced in this thread: How can I show camera frame in my Unity Project with Nuitrack Sdk?)

By default it’s at -1, in my case it’s ID was 2. I believe when I plugged the other camera in, then unplugged it, the order was changed and this threw an error. Setting it to -1 again let me pass the compatibility test and now that Unity isn’t crashing when I play I can find the colorstream ID again (1).

Do you connect your RealSense using USB 2.0 or 3.0? It’s important to connect it using USB 3.0.
You also can connect RealSense via USB 2.0, but in this case you have to set lower resolution for a depth map. To do this, open nuitrack.config (%NUITRACK_HOME%/data), find the section "Realsense2Module" and add the following lines to "Realsense2Module.Depth":
"RawWidth": 640,
"RawHeight": 480,

1 Like

The problem was the computer my company had me use, it was really bad. Windows ended up completely crashing and I had to reinstall everything. Nuitrack is working fine now! Thanks for your answer!

I had the same issue and iosif’s solution fixed it for me.

Although I am connected to USB 3.0, I’m connected via a USB switch. The switch is USB 3.0, but who knows, maybe there isn’t enough bandwidth to go around. I can’t connect directly to the computer right now, because it’s physically too far away from me. :slight_smile: