Compatibility Test on Nuitrack.apk Went Forever


#1

Hello,

I was following the instructions (http://download.3divi.com/Nuitrack/doc/Installation_page.html) to activate Nuitrack on my Android device, but after pressing “Compatibility Test” the screen turned black and the test won’t complete.

Below is the screenshot before the test: (System time check: OK)

The app didn’t crash though, as I pressed the back button it went back to where the app got started, and the activation key entry was grey. Below is the screenshot after I pressed back. (it said “Test completed” but actually nothing happened)

Some other information:

Android device: Samsung Galaxy Tab S SM-T700
Depth sensor: Orbbec Astra
Android version: 7.1.2
Nuitrack.apk version: 0.29.0
USB OTG support: Yes
Device rooted: Yes
Any pop-up window: No
Set 777 permissions for USB devices: Yes
Link to my Logcat: https://drive.google.com/file/d/1hYpcx8MbALfL5sMt3Cpl2qAIgr0_yTHC/view?usp=sharing

Has anybody got similar problems on Android?

Thanks,

Andy


#2

Hi , Andy

Me ,too.

Q) Can I use Nuitrack with RealSense and Android?
A)Yes. However, for RealSense with Android read permission for a root folder is required. You can check the permissions using any file manager, for example, ES File Manager: if the “/” folder is empty, then read permissions for the root folder aren’t granted in the current firmware version of your Android device.


#3

Hi Andy,

  1. What is VID and PID of your Android device?
  2. Try to delete Nuitrack and install it again, it seems that the issue can be connected to the installation process.

#4

Thanks for the reply.

VID = 18d1
PID = 4ee7

I have tried to reinstall the apk but it didn’t help. Do you have any other suggestions?


#5

Hi Olga,

I just went through the logcat and found some error/warning message below:

09-17 15:57:20.746 2858 2858 W PackageManager: Not granting permission android.permission.READ_EXTERNAL_STORAGE to package com.ceco.nougat.gravitybox because it was previously installed without
09-17 15:57:20.746 2858 2858 W PackageManager: Not granting permission android.permission.WRITE_EXTERNAL_STORAGE to package com.ceco.nougat.gravitybox because it was previously installed without

09-17 15:58:48.720 4461 4488 I NUITRACK: RGB device VID: 11205, PID: 1281
09-17 15:58:48.742 4488 4488 W Thread-7: type=1400 audit(0.0:293): avc: denied { read } for name=“usb” dev=“tmpfs” ino=3190 scontext=u:r:untrusted_app:s0:c512,c768 tcontext=u:object_r:usb_device:s0 tclass=dir permissive=0
09-17 15:58:48.742 4488 4488 W Thread-7: type=1300 audit(0.0:293): arch=40000028 syscall=322 per=800008 success=no exit=-13 a0=ffffff9c a1=b26a3996 a2=a4000 a3=0 items=1 ppid=2523 ppcomm=main auid=4294967295 uid=10076 gid=10076 euid=10076 suid=10076 fsuid=10076 egid=10076 sgid=10076 fsgid=10076 tty=(none) ses=4294967295 exe="/system/bin/app_process32" subj=u:r:untrusted_app:s0:c512,c768 key=(null)
09-17 15:58:48.742 2451 2451 W auditd : type=1307 audit(0.0:293): cwd="/"
09-17 15:58:48.745 4461 4488 I NUITRACK: WARNING: AstraProPerseeDepthProvider: No permissions for RGB device VID: 11205, PID: 1281

It seems that there may be something wrong with the permission to internal/external storage and the sensor.


#6

What Orbbec Astra model do you use (Pro, S, regular Astra…)? Please provide us with VID and PID of the sensor. Also please advise did you see a pop-up window asking for permissions after you clicked “Compatibility Test”?


#7

Hi Ogla,

Thanks for the suggestions.

Model: Astra Pro
VID: 2bc5
PID: 0401

I didn’t see any pop-up windows asking for permissions.


#8

Please try run the command chmod -R 777 /dev/bus/usb/ in the adb shell terminal. This command sets permissions for USB devices.


#9

Hi Ogla,

I ran the command you suggested in the adb shell terminal but it didn’t help. I double checked the file repository in root explorer on my Android device and it was set to readable, writable and executable by everyone.

I have also tried to install the Nuitrack.apk on other devices with different Android versions (5, 9, and 10) as well as testing on other Astra Pro sensors but none of them was able to finish the compatibility test, not to mention entering the activation key. In addition, I didn’t see any pop-up windows.

Do you have any other suggestions?

Thank you,

Andy


#10

Could you also suggest any type of Android devices that are most compatible with Nuitrack?


#11

We’ve tested Nuitrack with the following Android devices:

  • Odroid XU3 (Android 4.4.4 Kitkat) (rooted)
  • Samsung Galaxy S4 (Android 5 Lollipop) (non-rooted)
  • Samsung Galaxy S5 (Android 6 Marshmallow) (non-rooted)
  • Samsung Galaxy S6 (Android 7 Nougat) (non-rooted)
  • Samsung Galaxy S8/S8+ (Android 8 Oreo) (non-rooted)

#12

By the way, do I have to connect my Android device to my sensor via USB 3.0?