Depth frame looks cut-off in VicoVR app


I just tried running the VicoVR dev kit for the first time. However, it looks like the depth display is cut-off. (See attached pictures - there is no depth data above around the user’s head height and it also looks like skeletal tracking is affected by that.) Is my unit defective? There is nothing obstructing the camera, and I’m testing this in an environment where I usually use a Kinect v2. I’ve tried wiping the sensor down, and tilting the sensor towards the floor, but there is still a large portion of the depth frame without any data.


Some details:

Phone: Samsung galaxy S5 (SM-G900W8)
Android 6.0.1
VicoVr Android App 1.42 -> Settings -> “Test sensor”
VicoVr firmware 0.19.1
Device 20:72:02:00:00:49

This is very unusual. In general, depth may have issues with some backgrounds, did you try it in different location?
If it does not help it seems you need to send it back for replacement…

Hi sonnyb, please send serial number of your VicoVR unit to, we will update your VicoVR to beta version of firmware, which should resolve this issue.
Also please do following:

  • turn off VicoVR
  • wait for a 5 minutes
  • turn VicoVR on
  • check if any artifacts are presented and report to