Disabling RGB Stream on Azure Kinect in Nuitrack

Hi everyone,

I am working with an Azure Kinect in C# and I would like to disable the Color stream.

From what I recall, your base model for skeleton reconstruction (RegressionSkeletonization) only works with depth data – hence my attempt at removing the RGB stream.

After some trial and error, I applied the following configuration:

Nuitrack.SetConfigValue(“AzureKinectDepthProviderModule.ColorResolution”, “OFF”);

But then this exception was raised:

Is there a way to get Nuitrack to work with a disabled Color stream from K4A?

Thank you!

Hi @cg72

Currently we do not provide the option to disable color stream of Azure Kinect.
Are there any specific use cases for this?

Hi @cg72

Is this question still relevant for you?