Frame rate is low using SDK on Android platform

Dear all,

we are developing a hardware using ORBBEC PRO camera, the system is Android 7.1.2 using Rockchip RK3399 board , which contais 64-bits CPU, 2.0GHz, two Cortex-A72 core and four Cortex-A53 core.

During our experiments, we ran SDK on the hardware, only got 15 fps when detecting one person. If there are more than two users, the fps are merely 5 fps. Do you have any suggestions about how to improve the performance since the fps is too poor…

Looks very strange, Nuitrack running at 30fps on much weaker Android systems such as TVico/Persee, takes about 25% of processor power. Certainly it can be improved…

Hi Devin,

Please open nuitrack.config and set the "CPU MaxLoad" parameter to "-1". If this doesn’t help, please check your performance mode (using CPU Governor).

Thanks for your reply, I am wondering if you can give me a correct and detailed manual to use nuitrack on android platform, it will be wonderful if you can give me a description about nuitrack.config. We have tried many methods, still can not config nuitrack successfully. You can also contact me through my email:

Please advise what are USB ports on Rockchip RK3399 board? You can try to use a different sensor (if possible) or try to connect your sensor via a different USB port.

As for nuitrack.config, you can find it here: /sdcard/Android/data/com.tdv.nuitrack.sdk/files/nuitrack/nuitrack.config. Please use a file manager to open it, for example, ES File Explorer File Manager. Open the file, edit it (see my message above), save it and run Nuitrack once again.

Thanks for your help, problem is solved!

Thanks for your feedback. Just curious, what was the solution?

In fact, we still get some problem, as we bought license for Nuitrack.apk ( if we use trial version, the RGB and depth frame are both 320*240), the framerate is much better , we can get nearly 25 fps…

But, as we develop further, the frame size is different. The rgb image is 640 * 480, but the depth image and user_frame is poorly 320 * 240… we have tried to fix this problem using ES File Explorer File Manager to write nuitrack.config, but it doesn’t work…we also tried to use different usb port to connect our sensors, result is the same… can you help me figure our what is wrong with the sdk ?

In our previous development, we use Nuitrack with Windows platform. Now, we are trying to use Nuitrack on our Android platform, but we encountered some problems, we hope to get some advices from you

Hi Devin,

Please advise how do you set the resolution to 640x480? What section in nuitrack.config do you edit? What is your sensor?

You can find the instructions on how to set a different resolution on different sensors in our knowledge base.
See the questions “How can I change Depth/RGB resolution for Orbbec Astra Pro / Persee?” and “How can I change Depth/RGB resolution for ASUS Xtion2 / Orbbec Astra?”