How to reactivate sensor license in another computer

I’m trying to use the same sensor I bought a license for to run the application I created on a different PC.

How do I reactivate that license for my sensor on different hardware? Currently it’s giving me the 3 minute limit.

Hi bruno,

The reactivation process of Nuitrack on a different PC with the same sensor is as follows:

  1. Plug in the sensor and run Nuitrack activation tool;
  2. Click “Compatibility Test”;
  3. Wait until the test is finished and enter the license key;
  4. Click “Get Available Licenses”. The tool will show that you have “0” licenses BUT this means that you have 0 NEW licenses; your old licenses can still be used;
  5. Click “Activate”.
1 Like

I have run into a problem with licensing. I have multiple computers (Intel NUC) that I am experimenting with, so I may have confused the back-end server or something…

installed Nuitrack on a new computer and moved the camera to it. I ran
“sudo -E nuitrack_license_tool”, and it completed successfully, and the button on the far right say “Activated”.

But, when I run “nuitrack_gl_sample” it fails after 2 minutes with error "

I tried downloading and installing the latest Nuitrack runtime and SDK, (upgraded from 1.3.6 to 1.3.7) and still get the same error.

Environment variables:
$NUITRACK_HOME: /usr/etc/nuitrack
$LD_LIBRARY_PATH: /home/system/catkin_robot/devel/lib:/opt/ros/kinetic/lib:/opt/ros/kinetic/lib/x86_64-linux-gnu:/usr/local/lib/nuitrack

camera: Realsense D435 (worked Ok on my old computer)

cd ~/sdk/NuitrackSDK/Examples/nuitrack_gl_sample/build
Usage: nuitrack_gl_sample [path/to/nuitrack.config]
Press Esc to close window.
UVCVideoCapture::open ERROR: can’t find device
Can’t find video camera!
Can’t find Depth camera!
Create DepthProvider: Realsense2DepthProvider

<< runs for 2 minutes, works fine, then this error >>

LicenseNotAcquired exception (ExceptionType: 6)
Inconsistency detected by dl-close.c: 811: _dl_close: Assertion `map->l_init_called’ failed!

Suggestions for how to fix this?

Hi David,

  1. Please check that date & time settings on your PC are correct
  2. Delete the license.json file in usr/etc/nuitrack/data and activate Nuitrack once again

Thanks! That fixed it!