Init problem with Unity app on Android device

I created app for Android device with simple skeleton traking, but it even dont Init on device despite on Unity editor all works fine, Device is Rasberry Pi 4 with android on board, I get logs collected and it’s:

InitNuitrackLibraries() start
Nuitrack callback: onInitFailure

So that’s logs told that the problem is in this method

public static NuitrackInitState InitNuitrackLibraries()
		Debug.Log ("InitNuitrackLibraries() starts.");
			initComplete = false;
			AndroidJavaClass jc = new AndroidJavaClass("com.unity3d.player.UnityPlayer");
			AndroidJavaObject jo = jc.GetStatic<AndroidJavaObject>("currentActivity");
			AndroidJavaClass javaNuitrackClass = new AndroidJavaClass("com.tdv.nuitrack.sdk.Nuitrack");
			javaNuitrackClass.CallStatic("init", jo, new NuitrackCallback());
			while (!initComplete)
		catch (System.Exception ex)
			Debug.Log("Exception: " + ex);
            return initState;

Also nuitrack sdk app is installed and works fine
I can’t find cassification for this type of exeption “onInitFailure”
Use Orbbec Astra Pro Pluse sensor
Unity 2021.3.31.f1 LTS

  1. Which version of the app have you installed? (Nuitrack_arm64.apk or Nuitrack.apk)
  2. Have you downloaded the latest version of NuitrackSDK.unitypackage? (
  3. Send a screenshot of Build Settings. Identification and Configuration sections.
  1. Nuitrack_arm64.apk
  2. Yep, I download the latest one


UPD: I get logs with error code and it
Nuitrackcallback: onInitFailure

  1. What is the OS version?
  2. Try replacing these two files in the project in the plugin folder (Assets\NuitrackSDK\Nuitrack\NuitrackAssembly) with the most recent versions. and

LineageOS 20 Android 13
Device is rooted
I changed this files and build again, but still not works
The same log is appear

InitNuitrackLibraries() start
Nuitrackcallback: onInitFailure

Also I just tried to create an empty Unity project and build a tutorial scene(First Project/BasicSkeleton.scene)
Still not works

Also add logs

[11-01 13:28:35.451 1633:1652 E/Unity]
ArgumentOutOfRangeException: Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index
  at System.Collections.Generic.List`1[T].get_Item (System.Int32 index) [0x00000] in <00000000000000000000000000000000>:0 
  at NuitrackManager.get_Users () [0x00000] in <00000000000000000000000000000000>:0 
  at NuitrackSDK.Tutorials.FirstProject.NativeAvatar.Update () [0x00000] in <00000000000000000000000000000000>:0 

[11-01 13:28:35.454 1633:1652 I/Unity]
InitNuitrackLibraries() starts.
UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)

[11-01 13:28:35.466 1633:1652 I/Unity]
Nuitrack callback: onInitFailure
System.Reflection.RuntimeMethodInfo:Invoke(Object, BindingFlags, Binder, Object[], CultureInfo)
UnityEngine.AndroidJavaProxy:Invoke(String, Object[])
UnityEngine.AndroidJavaProxy:Invoke(String, IntPtr)
UnityEngine._AndroidJNIHelper:InvokeJavaProxyMethod(AndroidJavaProxy, IntPtr, IntPtr)

@IProroIK Try running this on your device test.apk - Google Drive

First of all sorry for late responce, we try to lower Androind version, but unforturnaly cant do it(
So it start, and device is ok too but it dont see the license, I`m sure that license is set up correct, tested on 3 devices rassbery pi4, rassbery pi 8(main device) and sumsung galaxy A71 all devices dont see license

@IProroIK Answered in PM.