Installation and reactivation issue d415


I am experiencing some issues with installing and reactivating my Realsense d415 on a different system.
I am running Windows 10.

When I try to install nuitrack i get the following error message, ignoring it makes the installation continue and finish.

When I run Intel Realsense Viewer I can use the Camera without problem. But when I run nuitrack_c11_sample.exe I get this after about 2 sec and the depth image freezes:

Running nuitrack.exe to try and reactivate the sensor generates these results:

But I cannot enter the activation key.

Has anyone experienced anything similar or have a clue about what could be causing this?
It works fine on my other system that also runs windows 10.

Hi HenrikF,

  1. Please run nuitrack_sample.exe and send us the console output.
  2. We’ve updated Nuitrack and created Nuitrack personal account. Please follow the instructions here: Nuitrack SDK(2019-05-20) activation network error (if you haven’t purchased Nuitrack licenses before, you can just create a new account instead of clicking “Forgot your password?”).

Hello again Olga!

  1. I did run nuitrack_sample a few times. First time it openend the image window, but it was all black and did not react to user input. The times after that it said that it could not open any RGB nor depth stream and now, finally, the program just crashes as soon as I run it, which is why I cannot give you any log output.
    It seems to me that the sensor somehow gets locked when nuitrack tries to open it? Because now I cannot even open it using the Realsense Viewer, which I could before I ran nuitrack_sample. Restarting the system does not clear this issue.

  2. I have now created a personal account for nuitrack, neat! However, I still cannot enter the activation key and now I get this instead:

    Perhaps I should try installing nuitrack version 0.27.0 and see if that works better for me?

Try this to see the console output:

  1. Go to the “bin” folder.
  2. Press Left Shift on your keyboard and right mouse click in this folder.
  3. Select “Open PowerShell window here”.
  4. Type in “nuitrack_sample.exe” in the command line, press Enter and take a screenshot of the output.

I just get this (nuitrack_sample.exe has stopped working):

  1. Do you connect several sensors to one PC or just one sensor?
  2. Please check Windows camera permissions: select Settings → Privacy → Camera and turn on “Allow apps to access your camera”.
  3. Can you run nuitrack_c11_sample?
  4. Did you install LIPS SDK to your PC?

Hello again, sorry for the late response.

  1. I have only the D415 connected. But I now seem to get the same behaviour even with it is unplugged.
  2. It is turned on
  3. Yes, I get this (the image freeze after about 1 sek)
  4. No, or are you reffering to the primesense SDK that is in the nuitrack installation folder?
  1. Please advise what device do you use? (desktop/laptop, its model…)
  2. What is the model of your display adapter (GPU, embedded graphics…)
  3. Try to uninstall Nuitrack using the maintenance_tool. Then, install Nuitrack again. If this doesn’t help, check that your display adapter drivers are up-to-date: Device Manager > Display Adapters > {your_device}. If necessary, update the drivers.
  1. We are using an Intel NUC 6i5SYH (Small and portable). It is not so high end, but we use it along with the Kinect2 and KinectSDK withhout issues.
  • Windows 10
  • RAM: 8GB
  • CPU: i5 6260U 1.8GHz
  • GPU: Intel Iris Graphics 540 (I.e. embedded Graphics in CPU)
  • Drive: SSD 850 EVO M at 250GB
  1. Tried both things without any improvement. The drivers were already up to date. Do I perhaps need a more dedicated GPU?

Thank you for your Quick responses!

Please try to run any third-party app with OpenGL. If it crashes or there are any errors, please provide us with the log.

Solution that worked for me: Run Nuitrack.exe as administrator.

I installed Google Sketch up and it will not start either. It crashes on start. The only log output I could find was this:

======== Starting GL ========
WGLUtils::IsExtensionFinderWindowClassRegistered: Class is not registered.
WGLUtils::EnumerateAttachedDisplayDevices: \.\DISPLAY1 : Intel® Iris® Graphics 540 : PT 1
WGLUtils::EnumerateAttachedDisplayDevices: \.\DISPLAY2 : Intel® Iris® Graphics 540 : PT 1
WGLUtils::EnumerateAttachedDisplayDevices: \.\DISPLAY3 : Intel® Iris® Graphics 540 : PT 1
WGLUtils::UtilsState::ctor: Max GPU perf is 1
GlInformation: Starting graphics capabilities tests.

So it seems to crash after trying to start the Graphics capabilities tests, which probably means that the Graphics capabilities are somehow inadequate? Or some library is missing?

Macrodose, I tried your suggestion, but it did not work for me. Thanks anyway!

I will be going on vacation for about a week now, so it will be a while until I can write again.

I have now tried on a new identical system.
My integrated GPU should support OpenGL up to 4.5 according to this:
On this machine I still get the error when installing nuitrack, everything else works fine except that I am not allowed to enter the activation key.
@olga.kuzminykh Do you know what could be the cause of this?

Log output when running nuitrack_c11_sample:

Activation tool (“Compatibility test”) uses nuitrack_sample.exe internally. Please advise do you still encounter an issue with nuitrack_sample.exe?

I am able to run nuitrack_sample.exe now, but it behaves just like nuitrack_sample_c11.exe, i.e. it stops after about 1 sec and tells me to get a license at nuitrack.
When I perform the compatibility test it seems to run the test, but very quickly and even sais it is done with the test, but it does not allow me to enter the activation code.

Please check %NUITRACK_HOME%/data folder after “Compatibility test” finished. Does it contain e24... file?

No, it does not. When I run the test it simply sais “Starting Test…” and then “Test Completed”.

Thus, nuitrack_sample.exe runs successfully but “Compatibility test” doesn’t show a window with depth images. Am I correct? Please advise what version of Nuitrack is displayed in the bottom part of “Nuitrack.exe” tool.

You are correct that nuitrack_sample.exe runs successfully. However, it stops after about 1 sec and asks me to get a license. The Compatibility test does show a depth image, however only very briefly, also about 1 sec. This is how it looks (the bar fills up very quickly):

I’m using version 0.28.1 of nuitrack.

If the test was completed successfully, you should see the file “e24b…” in the folder %NUITRACK_HOME%/data. If this file wasn’t created, it means that there’s some problems with permissions to the Nuitrack folder. Please try to run the activation tool as Administrator.