Installation freezes at 66%


#1

I tried to uninstall the old version of Nuitrack for Windows to install the newest one in the same folder but I am not able to finish the installation since it stops at 66%.
Any hints?


#2

Hi Francesca,

Did you uninstall Nuitrack from your system before installing the new version? Sometimes this can happen if Nuitrack wasn’t uninstalled.


#3

Hi, I’ve just encountered this issue.

I first attempted to uninstall my old version but the uninstall process got stuck at 33% and in the details it looked like it was waiting for a “yes/no” confirmation. But there was no way to interact with this.

So I stopped the uninstall process and manually deleted the directory completely.

Then when I tried to install the newer version, it gets stuck at 66%. Even though there is no old version. So now I’m stuck in a loop where it is impossible for me to install Nuitrack on my machine.

Do you have any ideas on how to fix this without having to format the machine at all?


#4

Managed to fix it. For some reason the uninstaller/installer didn’t have permission to remove or modify the NUITRACK_HOME registry key, even when given admin permissions. Manually deleting the key allowed the installation to continue.


#5

Hey @olga.kuzminykh

I had the same problem.
I was trying to install a newer version of Nuitrack.

There is no option to upgrade current version, and the setup also won’t let me overwrite the existing install, so I was trying to uninstall first.

Uninstall got stuck at asking to confirm (yes/no) to remove the system path value, but there is no way to select “yes” or “no”.

It also takes a while to realize the problem, as the “Details” window is hidden by default, so I spent a good 5 or 10 minutes just waiting for it to progress beyond 66% (sometimes installs/uninstalls get stuck at a certain percentage when deleting large amount of small files for example).

So I had to manually delete the Old version Install folder, and manually delete the “path variables”.
The new version Install got stuck at 66% at the same point asking the impossible to answer (yes/no) question.

This happens even if you run the install / uninstall as an admin.

Managed to re-install the new version after several attempts of folder, registry key and system path value deletes, and multiple system restarts.

So, Uninstalling/Installing a new version is a painful process at the moment.

Here is a screenshot:


#6

Sorry for these issues. We are aware of these problems and we’re trying to fix them at the moment. Currently, the working solution is as follows in this case:

  1. Run clear_sys_env.bat as Administrator;
  2. Run maintenance_tool;
  3. Install Nuitrack.