Is there a way to change RealSense Setting

My env: windows 10, RealSense D435, VivePro, Nuitrack Unity api.

When I do the tracking via Vive Pro, the Realsense IR seems interfere with the HMD (Head Mounted Device), where I see flickering of the scene.

I’d like to try disable IR emitter (or more specifically set laserstate=0) as suggested by RealSense forum. But it’s not an easy task.

I see you have this script CalibrationInfo.cs which starts at the beginning of sensor initialization. I wonder whether Nuitrack can allow me pass the parameter to RealSense via it or in a different way?


Hi Alan,

Did you try to turn off or turn away the sensor to check this effect? We’ve checked this issue in our conditions and didn’t face any interference (given that a distance between a sensor and a person is >1m).

You can also try to set the "LaserPower" value to 0.5 ("Realsense2Module" section) in nuitrack.config but this may lower the skeleton tracking quality.

Hi Olga, thanks for the help. I will try the config change.

The flickering is reduced in my office with sunlight. However, it’s very obvious in my lab where there’s only electric lighting. I totally disabled the emitter (use a duck tape), the flickering disappear, but as you said, the tracking quality is poor.


Try to turn off the light and check this effect in the dark.