Kinect v2 and Nuitrack Trial not working


I’m struggling to make the Nuitrack Trial work with my Kinect v2.
The captor is well detected. And I know that my captor is working as I tested it under the Kinect Studio.

When I click the “Try Nuitrack !” button, a black window with a white box appears, and then nothing :

When I try to launch “nuitrack_sample”, same thing. The log says : “Create DepthProvider: OpenNI2DepthProvider” and nothing else. Sometimes, it crashes with "terminate called after throwing an instance of ‘char const*’.

I see thay my Kinect v2 captor is turning on but nothing happens. Any idea of what might be happening ? I am using Windows 11, nuitrack x64 (last version) and my Kinect drivers are up to date.

I succeed to make it work for 2 seconds before puting my licence key, but it was freezing before finishing the compatibilty test, which was never ending.

Thanks !

Hi @AnselmeC

  • Try connecting your Kinect V2 to a different USB port
  • Please check that Kinect V2 is connected to the USB 3.0 port

Hi @AnselmeC

Has your issue been solved?

Hi, thanks for the reply, but this wasn’t the problem.
I tried opening every .exe in the demo folder, and one worked.


Hi @AnselmeC

Which sample has worked?
Is nuitrack_sample still not working?
We’re trying to investigate this issue as nuitrack_sample should work fine with Kinect V2