Low framerate on Orbbec Persee/Ubuntu

I’m seeing low framerate for skeleton tracking on a Orbbec Persee running Ubuntu 16. On the order of 1-2 frames/second. Is that common?

I haven’t tried on Ubuntu 16, but on Android the sample skeleton apps run at 30 frames/second.

Note: I’m not sure which Orbbec Persee you have, but any Orbbec Persees purchased around early 2018 and onwards come with a slightly improved graphics chip compared to the older Orbbec Persees. (There was no official announcement or change in model number.)

If anyone else has tried running Nuitrack on Ubuntu, it would be great to know if you are also running into low framerate issues.


it should work at 30 fps for all official Persee distros (Android-based and Linux-based). We also support recent Persee 2018 hardware revision. In case of any issues please submit request through feedback form at nuitrack.com

Very odd. After:

sudo apt-get dist-upgrade

Everything is running at 30fps. However, My second Persee with the same Ubuntu install runs “nuitrack_console_sample” without errors but seems to be caught in a loop after “Create DepthProvider: AstraProPerseeDepthProvider”. Any ideas?

Hi elsocko,

After running the nuitrack_console_sample, the console output is displayed only after the user is detected. The string "Create DepthProvider: AstraProPerseeDepthProvider” means that Nuitrack started successfully. Could you explain, what do you mean by “caught in a loop”?

I have 2 Orbbec Persee running Ubuntu Linux, side by side. One of them detects a skeleton and displays something like this:

Usage: nuitrack_console_sample [path/to/nuitrack.config]
Warning: USB events thread - failed to set priority. This might cause loss of data...
Create DepthProvider: AstraProPerseeDepthProvider
Right hand position: x = 235.829, y = 365.832, z = 1558.862
Right hand position: x = 225.930, y = 378.219, z = 1573.443

The other one, right next to it, only displays:

Usage: nuitrack_console_sample [path/to/nuitrack.config]
Warning: USB events thread - failed to set priority. This might cause loss of data...
Create DepthProvider: AstraProPerseeDepthProvider

It never seems to detect a skeleton. Is there any log file or debugging information I can dig through to figure out what is going on?

Hi elsocko,

Do you connect 2 sensors to 1 PC? Nuitrack doesn’t support connection of multiple sensors at the time.

I’m using Orbbec Persee devices. It’s a type of embedded device with the camera and computer in a single device.


Both have the same install of Ubuntu 16. On one device, running the “NuitrackSDK.v1.3.1/Examples/nuitrack_csharp_sample” sample yields this as expected :Screenshot_2018-10-01_14-07-37

On the second device, all I get is this, but no error messages:

Could you please check nuitrack_c11_sample first? Error messages are displayed in a console with this sample.

It seems that the issue may be connected to drivers. Please try to run the following command:
LD_LIBRARY_PATH=/usr/local/lib/nuitrack/ ./nuitrack_csharp_sample

I uninstalled nuitrack-persee-ubuntu-arm32.deb (which was version 0.21.0), downloaded the latest nuitrack-persee-ubuntu-arm32.deb. Everything is running smoothly now.

Hi elsocko,

I have Orbbec Persee running Ubuntu 16.04. I have dowbloaded NuitrickSDK which contained the Example “nuitrack_console_sample”. May I know how do you compile this example and generate the executable?

My Persee does not have cmake. I tried to install cmake with the command, “sudo apt-get install cmake” but it does not installed.

Hope you can provide some guidance.


Without cmake you won’t get very far developing on linux. When you run:

sudo apt-get install cmake

What’s the output?

Hi Elsocko,

I finally managed to compile and run nuitrack_console_sample and nuitrack_csharp_sample.

The issue is due to my LAN network connection. Although I can get reply from “ping google.com”, but It is not able to access the installation site
Cannot initiate the connection to mirrors.ustc.edu.cn:80 (2001:da8:d800:95::110). - connect (101: Network is unreachable) [IP: 2001:da8:d800:95::110 80]

I removed the LAN and connect the Wifi to my mobile hotspot and everything is working.

Now need to understand the SDK and then try to develop an application out of it.