Network Error (6) : SSL handshake failed in the old 0.23.0 activation tool


Because of customer maintenance, I’m using a very old version of Nuitrack (0.23.0).

Recently, the license activation tool seems not working, showing that “Network Error (6) : SSL handshake failed”.

(In contrast to this, the new version of Nuitrack runtime (0.35.x) seems working fine…)

Therefore, I can’t re-new (update) license file.

The product I made is also quite old so that It’s hard to update Nuitrack runtime to the latest one.

How can I manage to fix this? Thanks in advance.



Is this link available on your device?
If you have a proxy on your network for the Internet connection, you can configure it from the %NUITRACK_HOME%/data/nuitrack.config file (the Network.ProxyUrl item).

Yes, I could connect to with no issue on my device and I could also find the license information for the camera as well. Also, I don’t have proxy on our network.

When I type sudo -E nuitrack_license_tool, as you can see the picture the Network Error comes up straight away. I remember activating new cameras with 0.23 version maybe in May and there was no problem, but when I tried to activate Or test new camera recently, it doesn’t work anymore (it shows the same error in other devices that I checked).

We have many products using Nuitrack and it would be great if we can continue to use 0.23 version for activation. Could you please check if there has been any change that could affect the older version of activation tool (nuitrack_license_tool)?

Hi @robocare,

What version of Ubuntu are you using?
Try this command: ping

Hi @irakli thank you for your help,

We are using 16.04 Ubuntu and the result of ping seems normal

robocare@coggame:/usr/etc/nuitrack/data$ ping
PING ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=50 time=332 ms
64 bytes from ( icmp_seq=2 ttl=50 time=378 ms
64 bytes from ( icmp_seq=3 ttl=50 time=423 ms
64 bytes from ( icmp_seq=4 ttl=50 time=465 ms
64 bytes from ( icmp_seq=5 ttl=50 time=300 ms
--- ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 3999ms
rtt min/avg/max/mdev = 300.849/379.890/465.122/59.444 ms

I have checked the nuitrack_license_tool this morning, and somehow the Network Error (6) SSL handshake failed is not showing anymore, but it says System time check :OK. However, when I click Test button, it opens the Nuitrack window but doesn’t do anything and doesn’t finish the test (stays forever saying Starting test... .
FYI, this machine has other camera’s license info and that’s why it says ‘Activated’. As ‘test’ does not complete and I can’t put license code of this new camera, I can’t use this camera in this machine.

I have tried ping on another machine and it showed the normal result
(all packets transmitted and received) but on this machine it still shows Network Error (6) : SSL handshake failed. Thank you!

Hi @robocare,

I have tried ping on another machine and it showed the normal result (all packets transmitted and received) but on this machine it still shows Network Error (6) : SSL handshake failed . Thank you!

Check the date and time on these computers.

Please try to execute the application by path: /usr/bin/nuitrack_c11_sample and send us the output.

hi @irakli,

I have checked the date and time on these computers and they show current time.

When I execute /usr/bin/nuitrack_c11_sample, it opens a window saying ‘nuitrack c11’ and it shows the depth image. The output on the console was

Start nuitrack c11
Can't find video camera!
Can't find Depth camera!
Cannot identify '/dev/video0': 2, No such file or directory
Cannot identify '/dev/video0': 2, No such file or directory
Warning: USB events thread - failed to set priority. This might cause loss of data...
Create DepthProvider: AstraProPerseeDepthProvider

Even though the sample works, I still can’t use activation tool properly since clicking ‘Test’ button shows ‘Starting test…’ and never ends as I mentioned in my previous answers.

The problem persists even when I plug in another camera to the same device (new one that I didn’t activate on this machine yet), the nuitrack_c11_sample works with no issue but the nuitrack_license_tool doesn’t work properly (stays ‘starting test…’ for a very long time and says 'Test completed"). It seems like nuitrack is using old camera’s license information for executing sample and doesn’t let me type in the new license information (the place where I type in the license info is not activated and the button shows ‘Activated’ with grey color).