No skeleton image shown in the Test Sensor mode

I bought a VicoVR around Feb-10. I then followed the Android user guide to setup the app and VR.

There are several problems I can’t solve:
1/ The VR’s both LEDs glows yellow but just stay there permanently without proceeding to the status that the right LED turns yellow to finish booting.

2/ My host tablet is Samsung Galaxy Tab A. I downloaded the latest app and try to pair with the sensor through the app. The connection is unsteady. On off on off.

3/ After the pairing is done, I tried to test the sensor. My tablet displayed “connect to VR forever” on the screen without showing any skeleton. Then, the message reminded me of trying to unpair the Bluetooth from system setting, reboot,etc… I followed the instructions and tried several times end up being failed.

BTW, I read trouble-shooting threads on forums. I wanna know how to update the firmware? By dissembling the VR and take out the SD-card? What do I need to write into the VR’s SD-card?

The problem is deflating. Could you help me to fix it in order to show skeleton in the host device?


Both LEDs glows yellow permanently on the sensor. How should I fix it?

Hi Jake_Ding,

You have to update your VicoVR sensor firmware. Run the VicoVR app and update the firmware: select Settings --> Firmware Update.