Node process has died (seg fault)


#1

Hi,

I am trying to run a ROS node “nuitrack_body_tracker” as found on this repository.
Compilation goes without any errors.
Shortly after launch, the process dies with exit code -11 (a segmentation fault) as seen in this image:

Running it through gdb, this is what the frame shows:
Note the “aaaaaaaaa” and “bbbbbbbbbb” are test strings I made to track run progress.

This is the output of gdb bt (backtrace):

I have a working nuitrack trial license, and I am able to run nuitrack_sample with a 3 minute time limit.
I am using an Intel Realsense D435 camera, with a USB 3.0 connection.
Does anyone have any suggestions for how to solve this, or experience with similar issues?


#2

Hi Tim,

  1. Please advise what device do you use with D435 and Nuitrack?
  2. Are OpenNI utils installed to the system?
  3. Please provide us with the list of dynamic dependencies.

#3

Hi Olga,

I am using a PC with Ubuntu 16.04 and ROS Kinetic.
OpenNI utils arent installed but OpenNI2 utils were, however removing them did not change the situation.
I am not sure how to find the list of dynamic dependencies.

I have just been given an older NuitrackSDK (1.3.5) and installation .deb (0.23) that seem to have fixed the problem completely. I have also tried it with 1.3.8 and 0.23, this works successfully as well, and my colleagues say 1.3.10 works too.


#4

Hi Tim,

Thanks for your feedback!

If you get a chance, try to use the latest Nuitrack version following the recommendations below:

  • [If you use Nuitrack C++ API] Make sure that Nuitrack 0.28.0 is used with Nuitrack SDK 1.4.0, it’s important.
  • Try to move libSenDuck.so from /usr/local/lib/nuitrack/OpenNI2/Drivers/ to /usr/local/lib/nuitrack/OpenNI2/ (up one level)

#5

Hi Olga,
I had the same question. I am sure that I installed the Nuitrack 0.28.0 with SDK 1.4.0 but it can’t work.I also move the libSenDuck.so to up one level but it can’t work too.
If I switch the 0.23 and 1.3.5, the program works fine but my online license (nuitrack pro) can not use.
Is there any other solutions?
Thanks.


#6

Hi Olga,

I have set up a new computer with the up to date Nuitrack files (SDK 1.4.0 and deb 0.28) and tried moving the file that you suggested however I still get the same exact problem.


#7

We’ll fix this bug in the next Nuitrack release.