Nuitack.apk COMPATIBILITY TEST not completing


#1

I have a Orbbec Astra MINI sensor,when I connect with my android phone for activate the Pro version and hit Compatibility Test.after that the mobile phone has always been black. and I am unable to access “Get avaliable license”(the button is grayed out)

What should I do to avoid/fix this?


#2

Hi spyboy,

Please advise what is your Nuitrack version? It’s displayed at the bottom of the Activation window.
Also please provide us with adb logcat from your device.


#3

I have this same problem on an Nvidia Shield.

D435 Sensor with an android license but can’t enter the license code to activate and it does not complete the test.


#4

Hi Tim,

Please advise what Nuitrack version do you use? It’s displayed at the bottom of the Nuitrack activation tool window.

For RealSense + Android: Read permission for a root folder is required. You can check the permissions using any file manager, for example, ES File Manager: if the “/” folder is empty, then read permissions for the root folder aren’t granted in the current firmware version of your Android device.


#5

I built the Unity app using a PC one year license and just purchased a lifetime Android license.

Even though I have activated the PC version I still get the license exception on my PC if its used for more than three minutes.

I went through the activation process on Android, it wouldn’t let me place a cursor in the serial number field. Now, when I try to run the Nuitrack android app I just closes as soon as it opens.

The android app I made in Unity does not pick up the hand tracking.

Does it run and do the test after it’s activated, is the closing normal or is there something wrong?


#6

When I was finally able to activate the Android license it recognized the sensor but now won’t recognize it on any app even the Nuitrack.apk.

I exported an android version of your Gallery Sample unity project to test it and it won’t recognize the sensor in any way.

Does the device need to be rooted? Can I add or modify a file in the apk after installed? Does it a require a certain version of the Android API?


#7

What Nuitrack version do you use?

  1. Windows: Do you use the same sensor (with the same serial number) that you used when activating Nuitrack for the first time?

  2. Android: Please clarify - did you manage to activate the license on your Android device? Did you see the depth map after clicking “Compatibility Test”?

If yes, you can try to force stop Nuitrack.apk and other apps that use Nuitrack. Also you can try to re-plugin the sensor and restart the Android device. After that, try to run Nuitrack.apk again.

If this doesn’t help, please send us adb logcat (plug in the sensor and run Nuitrack) so we can investigate the issue. And also please clarify what do you mean by “apps won’t start” - do you see a black screen or any errors displayed in a window?

Android API should be at least 15 level.


#8

I’m running into the same issue trying to get my Samsung S8 running android 8.1 to complete the compatibility test on version 0.28.0 - I’m connected to a Realsense D435.
The Compatibility test doesn’t complete and the Activate field stays grey.
The device works in that other applications, like RS Camera, get input from the camera.


#9

Hi Brennan,

Please provide us with adb logcat. To get it, follow the steps below:

  • Plug in your sensor to your phone;
  • Run the sample;
  • Unplug the sensor;
  • Plug in your phone to your PC;
  • Run the command “adb logcat” and send us the output.

Besides, check this option:

  • Go to Developer options on your phone;
  • Select Default USB configuration and set it to MIDI.

Do you see a pop-up window “Allow access to USB” when you run the sample?


#10

Hi Olga,
Thanks for replying.
I plugged the sensor in (a Realsense D435) to the phone
I ran the Nuitrack Compatibility Test (just goes to black screen and does not return)
I plugged the phone back to the PC.
I ran adb logcat and output it to a fie. You ask for me to send this file, but I noticed that the forum does not allow me to upload txt files. I uploaded it to Wetransfer and it can be accessed from this link: https://we.tl/t-XWZcOSz3US

When running the sample, it asks to allow access to the D435 camera.

Thanks for any help you can give!