Nuitrack App crashing with Astra 2

Hi. I’ve just taken delivery of an Astra 2 camera. I’m running Windows 11 and have installed the Orbbec Windows Driver. I have installed the latest Nuitrack SDK (0.37.12). When I run the Nuitrack App I can see the camera (sometimes, I have to unplug and replug the camera for it to appear in the list). However, when I click “Try Nuitrack!” after a few moments the application crashes. I’ve tried both Classic and AI pose estimation methods and tried downgrading to Nuitrack SDK version 0.37.08 (which I belive was the first to include support for Astra 2) but I encounter the same issue. Thanks.

If anybody from the Nuitrack team is able to comment on the above I would be very greatful. We have a Femto Bolt camera on order so can hopefully test with this soon, but our end goal is to use Astra 2 so any advice would be appreciated. Please let me know if there is any further information I can provide that will help diagnose the issue.

Hi @jp887,

Sorry for the delayed reply.
Could you please check your Astra 2 sensor in the OrbbecViewer application?
Does your Astra 2 sensor work correctly in this application?
Is the sensor displayed as a USB 3.0 device?

Looking forward to your reply.

Hi @vadim.bazhin. Thank you for your reply.

In Orbbec Viewer the Astra 2 sensor is listed as a USB 3.0 device.
Upon opening the Orbbec Viewer I do see the following errors in the log, however the application seems to function correctly and I can see data from all of the sensors, point cloud etc.


@vadim.bazhin Some new information - since running the Orbbec Viewer the Nuitrack App now appears to be working consistently with Classical pose tracking! However, if I select AI pose estimation the original problem occurs. The app still crashes during the “Loading Demo” window.

Hi @jp887,

We have a known issue with the Nuitrack AI Skeleton Tracking mode and Zen 4 processors (as Andrew said earlier).
A fix for this issue is in the final stages of development and will be released in one of the next releases.
Thank you for your patience.

Hi @jp887,

Please try to check the new version of Nuitrack (0.37.14), there the problem with AI Skeleton Tracking and Zen 4 processors should be solved.

Hi @vadim.bazhin,
I can confirm that AI tracking is now working in version 0.37.14 for me. Thank you for your help.