Nuitrack C# Example - License Exception

Hi there, i have followed the c# example docs and i can run the program. I get a window showing the output of the Camera i am using which is an orbbec pro. This lasts a few seconds prior to throwing the exception -
nuitrack.LicenseNotAcquiredException: ‘NuitrackException (LicenseNotAcquiredException)’
However i have applied and activated a 3min trial license, so should this work ok, and if so what am i missing?

Thanks in advance

Do you see the depth map after you click “Compatibility Test”?
If yes, please go to %NUITRACK_HOME%/data. Do you see the file “e24b…”?
If the file is created, please close the activation tool and run it again.
If this file wasn’t created, please run the activation tool as Administrator.
If you don’t see the depth map after you click “Compatibility Test”, please run “nuitrack_sample” from %NUITRACK_HOME%/bin and provide us with the console output.

Thanks for coming back to me. I have run the compatibiklity test as admin, and yes in the sample doc i see the depth map, although i cant toggl to RGB on depth. When i toggle it freezes.

The file “e24b…” still does not exsist in the /data folder.

When i run the c# program example from visual studio i still get the same error, i see the depth map for a few secodns then it freezes and throws the above exception.


Hi! Please provide us with the information about your environment:

  1. OS
  2. Nuitrack version
  3. Sensor model

Also try running %NUITRACK_HOME%/bin/nuitrack_sample with the -cert flag. As a result, the “e24b …” file should be created in the %NUITRACK_HOME%/data folder.