Nuitrack_csharp_sample runtime error

First, introduce my development environment

  • Windows 10 Pro
  • Visual studio 2019
  • realsense 435
  • Nuitrack Pro Perpetual .

You are running ‘nuitrack_csharp_sample’.
The process I did is the same as that of readMe.

- Install cmake https://cmake.org/download/

- Run CMake and set source code directory to "nuitrack_csharp_sample" folder, build directory to "nuitrack_csharp_sample/build"

- Press Configure button, then select Visual Studio generator

- Press Configure, then Generate

- Open solution "Project.sln" in Visual Studio and use its instruments to build solution

- copy .exe binary from "build" directory to its parent folder (or build target INSTALL) and run sample from "nuitrack_csharp_sample" directory

nuitrack_csharp_sample/nuitrack_csharp_sample.exe is execute. However, only administrator privileges are possible.

I would like to develop as I change my code in debugging mode and see how it changes.

Run with ‘project.sln’ generated by cmake and you will get a run-time error.

The error details are:

    'C:\Users\devLupin\NuitrackSDK\Examples\nuitrack_csharp_sample\build\x64\Debug\nutrack_csharp_sample' 
    The program cannot start. 
    Access is denied.

Actually, I’ve tried defining administrator-only mode, turning off read-only, and adding folder permissions.
But the same error occurred.

What is the problem?

Hi, could you check administrator privileges for Nuitrack and try to run “nuitrack_sample” from “<nuitrack_install_dir>/nuitrack/nuitrack/bin/”?

1 Like

Yes, administrator privileges execute possible!