Nuitrack Debian32 Raspberry Pi 4 Astra Camera Installation issue

Hardware = Raspberry Pi 4 8Gb
OS = Raspbian 32 bit.( also tried with ARMUbantu64, Raspbian64 same issue)
3D sensor = Orbbec Astra S

I have followed the installation steps from official github page (nuitrack-sdk/ at master · 3DiVi/nuitrack-sdk · GitHub), When I run nuitrack licensing tool through terminal no sensor appear in device list. Seem like nuitrack is unable to find the connected astra 3d camera ( I tried switching from usb 2.0 to 3.0 ports but face same issue). Is there something I am missing here extra driver/package ? pls help.

Error on terminal: Get device list error: Can’t enumerate devices AstraProPerseeDepthProvider(Deviceopen using default: no device found)

Hi @microjojo

It’s known issue that latest Nuitrack version for linux arm platforms doesn’t work with Orbbec sensors.
You can try Nuitrack v0.35.6 as quick workaround.

Hi @microjojo

We you able to run your astra on Nuitrack v0.35.6? Do you have any other questions I can help you with?

Hi @a.bragin

I have had the same issue and I have looked at the Nuitrack v0.35.6, however, the package doesn’t include the version of arm64 which is required by Raspberry Pi 4. Would it be possible that you add it to the package please?

Hi @hz321

Do I understand correctly that you want to use orbbec astra in linux arm64?
Currently, nuitrack doesn’t support orbbec astra sensors in linux arm64.

Hi @hz321,

Do you have any other questions I can help you with?