Nuitrack for Unity3D

I am setting up the Nuitrack sdk for Unity3D with Intel RealSense, however, I encountered above error. Can someone please enlighten me how to solve this.

Hi ahboyboy8989,

Please make sure you connect your sensor using USB 3.0.

Also, try to run nuitrack_c11_sample.exe (nuitrack-win64\nuitrack\bin). Does it work?

Hi Olga,

Yes, the sensor is connected to the computer via USB3.0
It runs well on the nuitrack_c11_sample.exe

I suspect something wrong on the unity: DllNotFoundException: libnuitrack
Other people are having similar issue.

1 Like

Hi Olga,

By following the steps in Can't find out how to properly setup Nuitrack, i managed to run the tutorial in Unity.

The root cause is setting up the class path in a non-public directory.

Glad it worked for you too!

hay can you tell me you can use usb3 connect computer and sensor ? by unity3d
It work or not ?

Yes, I was using USB3.0 to connect the sensor with to computer. It worked fine with unity3D after following the steps mentioned in this post Can't find out how to properly setup Nuitrack

In fact, You NEED usb 3.0. 2.0 wont work.