DllNotFoundException: libnuitrack

I’ve confirmed that Nuitrack is installed and activated.
When I try and run the Unity room demo I get the following error

DllNotFoundException: libnuitrack

Can someone tell me what I need to do to tget the Unity demos working? I have ‘Any Platform’ checked for the nuitrack.net plugin.

First of all check if you done nuitrack installation correctly.
Seems like a lot of people having issues with wrong environment variable values.

No. As mentioned I’ve confirmed nuitrack is installed and activated properly. I can run the non-untiy demos.
I’m thinking there is a dll file that is missing from the Unity project folder…

Please check dll import settings in unity.
Assets/NuitrackSDK/Nuitrack/NuitrackAssembly/nuitrack.net.dll , set Any Platform check.

Is it resolved? Got same issue on unity 2018.2.1f1.

It seems the updated sdk and jdk1.8 did the trick on this version of unity.

Hi, I have same problem, about a couple of weeks it worked, but now shows that error. It happens using unity 5.5.4p4 and 2017.3.1.p3
What can be happening?

Hi, it is the same with me. The installation is correct and the c# samples provided by nuitrack work properly. I just can’t get my unity builds to run using unity 5.5.4 personal edition.

Please make sure that you use 64-bit version of Nuitrack with Unity.

Hello, Olga.
Today I downloaded the nuitrack to test my new pc.
But it didn’t work because of this exception.
So I replaced nuitrack with nuitrack file of old pc.
Then, it didn’t throw exception.
What happened between version 0.22.1 and version 0.23.1?

Hi younger,

Do you encounter this error when running Unity samples?

What is the “nuitrack file” that you replaced?

I do use 64-bit version. Unfortunately I still run into the the same trouble.

There could be the following solution to this problem:

Hi Olga, first of all, thanks for the help. I already have set the import settings in that way.
Still getting the exception in the Unity examples and my own builds. I also use x64 version and triple checked the environment variables. They all echo correctly. C# examples also work out with my Orbec Astra and RealSense D435 (Is that actually a proper test to see if the installation works correctly?).

However, when I reinstalled the sdk lately I encountered an error in the CamRotation script “GameVersion does not exist in the context”. I had to comment those sections out in order to get started. What does GameVersion do and could it be a reason for my missing DLL issues?

Is there a way to manually copy the nuitrack LIB in the build folder of the Unity project?

Hello Olga,
I’m sorry I didn’t write well.
I downloaded version 0.23.1 at nuitrack.com and played it but didn’t work.
So I changed version to 0.22.1 then it didn’t throw exception.
I think 0.23.1 has this problem and this post uploaded after version update.
Thank you.

Hi Letgo,

We’ve reproduced your issue.

When importing NuitrackSDK.unitypackage to your Unity project, you have to tick all the components (folders, scripts…) shown in the window “Import Unity Package”. They’re all ticked by default. It seems that you unticked some folder or script.

4 months later and still no satisfactory answer. Can anyone tell me where to simply get ‘libnuitrack’ DLL file so I can manually install?

I found it in nuitrack-win64\nuitrack\bin

Hi Olga,

I am having a similar issue. I am trying to see if Nuitrack will work with my companies software to replace the Kinect, but this issue is blocking any progress. I have the nuitrack_c11_sample working fine, I just cannot get the C# example solution nor the Unity example to work. I’ve tried reinstalling everything, checking my environment variables, and checking my versions. My visual studio solution won’t let me manually add the missing references to the solution. I had it working at one point a couple weeks ago but now it doesn’t. Is there any solution you can think of? Maybe I could try using an older version of Nuitrack?

Anybody find any solution regarding dll not found exception?
Ive also imported the dlls from the installation folder to unity but still having same issue