Nuitrack SDK(2019-05-20) activation network error

I checked the license key at and activated it.
Please notify users that the activation method has been changed.

Thanks for your feedback! We’ll send the newsletter shortly.

Hi Olga,
Is this a change in the Unity SDK or in the Nuitrack SDK?

I updated the Nuitrack SDK package in my project but the problem still persists. :confused:

Please update Nuitrack Runtime to 0.28.0 as well. In this version, we created Nuitrack personal account and changed licensing procedure. Please reactivate Nuitrack as described above.

Hi, when I try to active my license, now I get an error saying:
System time check: OK
Network Error (302): Error transferring - server replied: Bad RequestFailed: ‘\tlicense’

Bad RequestFailed: '\tlicense' means that you copied an extra symbol (tab or space) when copying the license. Please make sure that you copy the license key correctly. In the near future, we’ll add the “Copy” button to prevent such situations.

Trial method not working. I have tried using password reset method without any help. It says invalid email or password.

Want to use in Unity3D but getting this error.

LicenseNotAcquiredException: NuitrackException (LicenseNotAcquiredException)
nuitrack.NativeImporter.throwException (nuitrack.NativeImporter+ExceptionType type) (at :0)

Hi Prasanna,

After you reset the password, you receive an email with the confirmation link. After you click this link, your password reset is confirmed and you can enter your account. However, you didn’t confirm the password reset. Anyway, we manually confirmed your account so you can enter it (use your email and password).

To generate a trial license, follow the instructions:

1 Like

Thanks for the reply and suggestion.

Whilel trying to activate a trial license I see that the window freezes just after clicking “Compatibility test”.

How to solve that? Using Ubutnu 16.04. Latest version of .deb file installed.

Any way there exists another problem and that is even I after manually pointing libraries for middleware and other includes I see a problem related to the following.

Usage: nuitrack_console_sample [path/to/nuitrack.config]
WARNING: Can not load library module: /usr/etc/nuitrack/middleware/
ERROR: Empty factory for DepthProvider
Can not initialize Nuitrack (ExceptionType: 2)

Would be nice to have a guide on how to solve these issues.

Please run the following command and provide us with the console output:

ldd /usr/etc/nuitrack/middleware/ | grep curl

This is what I’m geting with the command above stated.

pkumars@pkumars-GL503VD:~$ ldd /usr/etc/nuitrack/middleware/ | grep curl => /usr/lib/x86_64-linux-gnu/ (0x00007f7d7363a000)
pkumars@pkumars-GL503VD:~$ ldd /usr/etc/nuitrack/middleware/ | grep curl => /usr/lib/x86_64-linux-gnu/ (0x00007f9fa3eb0000)
pkumars@pkumars-GL503VD:~$ ldd /usr/etc/nuitrack/middleware/ | grep curl => /usr/lib/x86_64-linux-gnu/ (0x00007f1c13c03000)
pkumars@pkumars-GL503VD:~$ ldd /usr/etc/nuitrack/middleware/ | grep curl => /usr/lib/x86_64-linux-gnu/ (0x00007fcc65109000)

ldd /usr/etc/nuitrack/middleware/ | grep not => not found => not found => not found => not found => not found => not found => not found => not found => not found => not found => not found => not found

Please run the following command:

export LD_LIBRARY_PATH=/usr/local/lib/nuitrack

Ok. I run
export LD_LIBRARY_PATH=/usr/local/lib/nuitrack and export NUITRACK_HOME=/usr/etc/nuitrack .

then I try ldd /usr/etc/nuitrack/middleware/ | grep not —> no result and that means it found the path correctly.

I close the terminal and then try the same after opening again and get same error of not found.
ldd /usr/etc/nuitrack/middleware/ | grep not => not found => not found => not found => not found => not found => not found => not found => not found => not found => not found => not found => not found

I have put this in my .bashrc
export NUITRACK_HOME=/usr/etc/nuitrack
export LD_LIBRARY_PATH=/usr/local/lib/nuitrack

and still unable to find path.

Anyway for the path valiable I can run with every new terminal.

The problem is I’m unable to enter license key in nuitrack_license_tool.
It detects the camera, gets a depth stream but after that I’m unable to enter the license key.

I have tried wth reinstallation and reboot.

Using Ubuntu 16.04.

I want this issue to be solved as soon as possible.

I shall wait for a quick help.


Please run the commands:

Then, run the activation tool and try to activate Nuitrack again.

1 Like

It Worked!

But I need to use “export LD_LIBRARY_PATH=/usr/local/lib/nuitrack” again and again.

Anyway this is OK for testing.

Try to set the environment variables using the following commands (as root):

echo "export NUITRACK_HOME=/usr/etc/nuitrack" > /etc/profile.d/
echo "export LD_LIBRARY_PATH=/usr/local/lib/nuitrack" >> /etc/profile.d/
. /etc/profile.d/
1 Like

Thanks for the info, but I do have the same thing already in

export NUITRACK_HOME=/usr/etc/nuitrack
export LD_LIBRARY_PATH=/usr/local/lib/nuitrack

Hi, when I try to activate my license, I get the message: Network Error (299): Error downloading - server replied: Bad RequestFailed: License signature is incorrect. Invalid signature.
I’m copy pasting the license just generated from
Thanks for help

Hi Massimo,
Please provide information about your OS and depth sensor.
Also attach data from “$NUITRACK_HOME/data/e24b*” file generated by compatibility test.