Nuitrack SDK on Ubuntu 18.04


I tried to compile the nuitrack_console_example on a fresh Ubuntu 18.04.
The program tries to link against,, which are both not available in the ubuntu index. Does anyone have experience in setting up under 18.04?


I found the mistake (was a bit too quick) … I used a shell where the environment variables from /etc/profile.d/ were not sourced yet.

However, no I run into the problem when running the application

Usage: nuitrack_console_sample [path/to/nuitrack.config]
WARNING: Can not load library module: /usr/etc/nuitrack/middleware/
ERROR: Empty factory for DepthProvider
Can not initialize Nuitrack (ExceptionType: 2)

When I check the .so file with ldd, I see that is required. The installation page states to install the libpng12-0 package on 18.04 which does not exist.

For completeness and to close this thread: One has to download and install the .deb that is intended for Ubuntu 16.04 (works with 18.04)

sudo dpkg -i libpng12-0_1.2.54-1ubuntu1.1_amd64.deb