Nuitrack SDK with RealSense D435 on Android Pie 9


  • Intel RealSense D435 with
  • Galaxy S10 with Android 9

Recently I got a Nuitrack Pro SDK license for Android and I tried to test Nuitrack SDK with my device running on Androrid 9(Galaxy S10). But I have an issue to use it.

Installation was good and but nothing happens forever when I press COMPATIBILITY TEST. It shows just black blank screen. Log can be found here(deleted).

nuitrack_gl_sample in Nuitrack SDK package
The application crashed in native library and here is a snippet of the logs. Full logs are here(deleted).

05-16 23:17:13.227 F/DEBUG   (21038): backtrace:
05-16 23:17:13.227 F/DEBUG   (21038):     #00 pc 0001cefe  /system/lib/ (abort+58)
05-16 23:17:13.227 F/DEBUG   (21038):     #01 pc 0001d43f  /system/lib/ (__assert2+22)
05-16 23:17:13.227 F/DEBUG   (21038):     #02 pc 00079e09  /data/app/com.tdv.nuitrack.sdk.samples.NuitrackGLSample-BkQj4xcg5X25glte7ZV7wg==/lib/arm/
05-16 23:17:13.227 F/DEBUG   (21038):     #07 pc 0004910d  /data/app/com.tdv.nuitrack.sdk.samples.NuitrackGLSample-BkQj4xcg5X25glte7ZV7wg==/lib/arm/ (tdv::nuitrack::ExceptionTranslator::generateExceptionByErrorCode(tdv::nuitrack::ExceptionType, char const*)+512)
05-16 23:17:13.227 F/DEBUG   (21038):     #08 pc 00047121  /data/app/com.tdv.nuitrack.sdk.samples.NuitrackGLSample-BkQj4xcg5X25glte7ZV7wg==/lib/arm/ (tdv::nuitrack::DepthSensor::create()+56)

I have checked sample applications on diffrent devices which have Android 9, but nothing happened too.
However, they work well on the same device if they are running on Android 8 or earlier.

Does Nuitrack SDK for Android not support Android 9 yet?


1 Like

Hi Seongjoon,

Indeed, we’ve reproduced the issue with RealSense, Android 9 and Nuitrack. We’re working on the solution.

I am facing the same issue. Can you please suggest what is the workaround for this?

Hi @Sudheer

our team is still working on this issue.

Can you please clarify on which Android versions the Nuitrack is working? Thanks!

Hi @drAndrew

Nuitrack supports Android 5, 6, 7, 8 versions at the moment. However it’s better to test Nuitrack (with a free trial license) first as specific Android devices and USB cameras could have compatibility issues related to the USB subsystem.

Let us know if you have any questions or issues.

Thank you @mikhail.khayrislamov . We will test it on 7.1 with intel realsense D435. Would you have any advices regarding usb configuration? Or how to check the subsystem compatibility?

@drAndrew please refer to this section of Nuitrack Online Documentation. Let me know if you have new questions.

thank you @mikhail.khayrislamov. it worked. can you advise how to setup a view for the depth camera to 0.5 - 3m range?

You can specify the distance in the “Segmentation.MAX_DISTANCE” parameter in the configuration file or use Nuitrack :: setConfigValue (). Please note that the recommended distance for RealSense sensors is 1.5 - 2 meters.

thank you @iosif.semenyuk, pls tell me the exact value to specify to have a distance of 3m

By default, “Segmentation.MAX_DISTANCE” is set to 7000. This means that the entire segmentation module will not work if you are more than 7 meters away. To set a limit value of 3 meters, you need to set the value of this parameter as 3000.