Nuitrack test D435 error

Hi everyone,

I tried to test my D435 with Nuitrck app but get “Couldn’t resolve requests”. I did not know what is going on here. Can someone help me solve it? I also use the USB3 port to connect the camera.

More details:


Hey, @RickYang2014.

Realsense sensors are sensitive to cable quality and usb type, so we recommend you check the connection. Also, we suggest you check if the official realsense viewer is working properly with your sensor. (link). It would be great if you attach a screenshot of the realsense viewer with usb type to make sure the problem isn’t with the connection.

We’re looking forward to your response.

Hi gvr,

Thank you very much for your suggestion. I find the problem is the cable like you said.
I change a cable and it works. Great product.


Hi, @gvr

I have a further question. Do you have recommend VR which can combine Nuitack, D435 and Unity in a same scenario.


Hey, @RickYang2014.

Could you, please, describe your matter in more detail?

Hello @RickYang2014

Theoretically, any VR is suitable. Even some Apple Vision Pro.
We have a tutorial for Oculus, but it can easily be adapted to any other.

1 Like

Hi @Stepan.Reuk and @gvr ,

Thank you for your suggestions. I will look into it.
If I have any questions, I will let you know.


1 Like

Hello, @RickYang2014.

How’s it going? Are there any other questions you need help with?

Hi @gvr and @Stepan.Reuk,

I have a question about Linux system support, especially the Ubuntu 20.04.
Since currently do the experiment in the Ubuntu, which can support Nuitrack, ROS, and Unity. However, I can not find a suitable AR or VR supporting the Linux (Ubuntu) to develop my experiment. So do you have any suggestions about it?


We haven’t tried running VR on Linux. But it probably should be possible.
First you need to find out if VR works in Unity on Linux. And, if it works, which VR headsets are supported

Hey, @RickYang2014.

How are you doing? Do you have any other questions?