Nuitrack unity demo fails at initialization


I’m currently evaluating nuitrack in order to use it as a kinect replacement in a unity project. My setup: unity 5.5.0.f.3, win 10 and a Orbbec Astra Pro sensor. The nuitrack_c11_sample.exe works just fine and I also upgraded to nuitrack pro already.

The RiggedModel2 sample throws the following exception:

I followed the installation description and checked the path variables several times. Everything seems to be ok, except for the initialization errors. Is there something I could miss?

Thanks in advance

Hi kfe,

Please, check out the Westa’s reply below:

Also, make sure that you open the Unity editor only after you set the environment variables.

Thanks for your reply,

I checked NUITRACK_HOME and the PATH variable again. Everything seems to be in order. I have noticed that the nuitrack_c11_sample.exe gives me the following error message, apart from that this program runs error-free…

Could it be a problem that I am not building for an Android device, but only for my local Windows machine?

Thanks for your advice

FWIW the nuitrack c11 viewer shows a lot of messages - that are not technically errors
Its more a log of what its up to.

The ERROR message is kind of a misnomer in this case - yes it didnt open a RGB screen because you have not told it to - but to my thinking it does not really make it an error.


1 Like

I haven’t been able to solve the problem yet… I tried to initialize nuitrack with nuitrack.Nuitrack.NuitrackMode.Debug. No exception occurs, but skeleton tracking still doesn’t seem to work. Furthermore, the program cannot be debugged because unity crashes immediately after startup.
Could this information maybe of any help in solving my problem?

Hi kfe,

No, this shouldn’t be a problem because Nuitrack SDK allows to build Unity projects for Android.

As for nuitrack.Nuitrack.NuitrackMode.Debug, please, don’t use it because it is intended for a different purpose. Default nuitrack.Nuitrack.NuitrackMode.Release should work properly, so your issue isn’t caused by NuitrackMode.

We received TerminateException when NUITRACK_HOME environment variable wasn’t set correctly and Nuitrack couldn’t locate middleware/NuitrackModule.dll library. Make sure that the environment variable is set to entire system.