Nuitrack with RealSense stopped working after windows update

------- SOLVED ----------
I’ve tried another USB port. now it works. looks like my other USB stopped working properly.

I’ve recently update Windows 10 and it looks like nuitrack stopped working. (it still worked a week ago)
the windows update version:
2018-09 Update for Windows 10 Version 1803 for x64-based Systems (KB4100347)

I have a minimal c# project, just using HandTracker.
when I try to create a HandTracker:
try {
_handTracker = HandTracker.Create();
} catch (System.Exception exception) {
Console.WriteLine(“Cannot create Nuitrack module.”);
throw exception;
I catch a ModuleNotInitializedException

Exception’s stackTrace:
at nuitrack.NativeImporter.throwException(ExceptionType type)
at nuitrack.NativeHandTracker…ctor()
at nuitrack.HandTracker.Create()
at WpfApp1.MainWindow.StartCamera() in D:\csharp_workspace\nuitrack\example\WpfApp1\MainWindow.xaml.cs:line 72

nuitrack_c11_sample.exe doesnt work anymore either.

I’m using RealSense D435, RealSense Viewer works fine and displaying the camera’s output. so the issue is in the nuitrack.

** edit - I’ve attached a screenshot of the nuitrack_c11_sample’s console output **