"Orbbec Astra 2" make problems - "Orbbec Astra Pro" is fun


Since a while I’m a happy user of Nuitrack but today I got a lot of questionsmarks.

I have here an “Orbbec Astra 2” and a “Orbbec Astra Pro”
OA_Pro no Problem
OA_2 many Problems in Classical Pose Estimation and AI

I think the Depth-Information must be enough and the results of OA_Pro are good - so I want to focus on “Classical Pose Estimation” - The AI Problems are another chapter, now only - RegressionSkeletonization

I tried to change something in “nuitrack.config” or in “OrbbecSDKConfig_v1.0.xml”
too many parameters - I got lost

it seems ok when I’m close to 1.5m to the sensor - behind flickering and frontal body always lost - it often comes back when it sees me from side but then again gone when I tilt
when I’m 3m away and I enter from the side - the skeleton appers but as closer I come to the center gone - when I tilt my body to the side back again - front gone
Also tried with “nuitrack_device_api_sample.exe” 640x480 both - skeleton only detected from side not from front - CRAZY

I was always thinking there is an issue with the DepthInformation but 640x480 is like OA_Pro
these are all Problems with OA_2 - with OA_Pro all fine
just write if there is more info for clarification needed

is the solution hidden in “nuitrack.config” or in “OrbbecSDKConfig_v1.0.xml”?
or is because of Beta implementation of OrbbecSDKDepthProvider?
OA_Pro uses the OpenNi2DepthProvider


Nuitrack 0.37.14
Orbbec (SensorDriver_V4.3.0.20)

Hi Daniel, thank you for your feedback.
Nuitrack+Astra2 should work good without any parameters fine-tuning, so let’s proceed step-by-step to figure out what the issue is.
Could you kindly record a screencap or (better) Nuitrack recording for the problematic Nuitrack behavior ?
Then we’ll be able to dive right into resolution of any possible issues on Nuitrack side.
Feel free to choose between continuing here and creating a support case/ticket.


thx for the offer

I made ticket - because not possible to upload all the recording data here
and even in the UploadSection from the ticket - it was not written that the File should be below 5MB
The ZIP of the recording 15sec is nearby 300MB
So I delete a lot of the recording (6pics left) and sent it
I don’t know if the issues gets visible by this less data
I sent the pics when I’m 2m away and get not tracked