Orbbec Astra on Android OS (Unity build)

We’we tried Nuitrack unity samples on windows with Astra sensor and these worked fine,
but when we tried to switch target os to Android and run same examples nothing worked.

We’we tried to run Nuitrack.apk and run compatibility test, which resulted to black screen.

Here some info about our setup:

Vendroid Box

Device info

Error from Unity sample scene called “allModulesScene”

We also tried Realsense sensor and it worked well with both nuitrack.apk and unity sample scene.
Astra unity example from https://orbbec3d.com/develop/ worked well.
So i think that problem could be in Astra camera channals or something like that, becouse when we tried to connect Astra to windows there was also problem with getting color feed, this problem was solved through nuitrack.config -> AstraProPerseeDepthProvider": { "Windows": { "CameraID": 0 } }

Any thougts about this issue?

Hi Artur,

Please provide us with adb logcat (plug in the sensor, run Nuitrack, click “Compatibility Test”…).
Is your Android device rooted or non-rooted?


I am Arthur colleague - I will answer on this.

Well, it is hard to say, it is an Chinese Android “computer” that is made for Vending machines, so I believe it can be both. The thing is that we could manage to get realsense working, but not Orbbec.

Would that make a difference?

Hi Ainars,

Please send us adb logcat (after you plug in the sensor and run Nuitrack) from your Android device so we can investigate the issue.