Problem with nuitrack Pro

HI I’m having a strange problem.

I activated nearly 6 month ago nuitrack in a pc. if I run the demo in that pc it says in the top-left corner: “Nuitrack Pro” in yellow.

But when I run a software made by me in Unity, it stop working after few minutes and it says:

LicenseNotAcquiredException: NuitrackException: LicenseNotAcquiredException
_ at nuitrack.NativeImporter.throwException (ExceptionType type) [0x00000] in :0 _
_ at nuitrack.NativeNuitrack.Update () [0x00000] in :0 _
_ at nuitrack.Nuitrack.Update () [0x00000] in :0 _
_ at NuitrackManager.Update () [0x00000] in :0_

Is there something that I’m missing?

thank you!

Is it possible that the problem is that I changed the sensor? I’m using a lot of different sensors…is the license bond to a single sensor? I have like 30 Orbbec Astra and 20 Intel (4 different kinds). How can I know which one is the right sensor? Can I change the sensor if it will broke?

Hi Guybrush,

Nuitrack license is bond to a sensor serial number. If you use a different sensor, you have to purchase and activate another license.

Currently, we’re developing a personal account for Nuitrack clients. In your account, you’ll be able to see the list of purchased licenses and associated sensors. At the time, you can send us the license.json file, which is created after activation, and we’ll send you the corresponding serial number of the sensor.

For testing and development, you can use Nuitrack Trial (free download is available at our website). It has the same functionality as Nuitrack Pro but has 3-minute time limit.

I sent you the json by PM.

Isn’t possible to have a different kind of license? Just let me know if it’s possible to have some other kind of contract.

Thank you!

Please contact