RealSense D435 - Windows 10 - No example working


I’m working on Windows 10 and I’m trying to use Nuitrack (v0.29.0) with a RealSense D435 (SDK v2.29.0, also tried with v2.25.0 and v2.31.0; firmware I’m using the free trial version of Nuitrack, since I want to make sure I can use it for my project before paying for a license.

I did the installation several times (just to check if I wasn’t missing something) but I do everything according to the installation tutorial and my environment variables are properly set. A friend also tried and has the same results so I know the installation process is not the problem.

I can run the .exe samples, except for nuitrack_ni_sample but I understand it is normal with a RealSense camera.

My problem is when I try to build nuitrack_console_sample (and the others). I follow the instructions in the README files but none of them runs, each with a different error.

This is the error I get when I try to run nuitrack_console_sample:

I’m not working with an Astra Pro Persee (and never have) so I don’t understand why this comes up. The other issue here is the error, which is really weird as I’m working on Windows and .so files are Linux files.

When trying ot debug, the first (of many) error I get is:

Also, I have this:

Could it be the source of all the other errors? Does that mean I cannot run the examples without buying a license? That would be a real problem for me, I don’t have enough money to “waste” some on a license for something that might not help me reach my goal. If it works well I’ll definitely buy it.

Can someone help me please? Thanks!

  1. API version mismatch is caused by two versions of the RealSense library installed on your computer (one version from RealSense SDK and another one from Nuitrack SDK). Nuitrack is compiled with librealsense.dll v2.17.0. Please update your RealSense SDK or just back up (for example, rename) this file in RealSense SDK on your PC.
  2. By default, nuitrack.config is selected in the DepthProviderManager, it initializes each of the providers (Astra, Realsense …) to understand which of the sensors you are currently using. Therefore, you can see the console output from all providers.
  3. Nuitrack will not work without activation. For testing, you can activate a trial license, which limits the operating time of Nuitrack to 3 minutes. After 3 minutes, you have to restart Nuitrack.
  1. Why is it talking about v 2.25 and 2.29 then? I’ll try with v2.17 and renaming the RealSense SDK folder if it fails, thanks! And how how about the .so file?
  2. Ok so it’ normal.
  3. Nuitrack was already activated with the trial license. Any other lead on why I had that one?

Thanks for the answer!