Running on odroid-XU4

I wanted to know if it is possible to run the skeleton tracking middleware on a odroid-XU4 running ubuntu 16.04 with ROS. Has anyone had any success with the same?

Hi Pradeep,

You can use Nuitrack with ODROID-XU4 but it should have ARMv7 architecture. In this case, you can download Nuitrack Trial for Orbbec Persee + Linux ARMv7 at our website.

Yes, its an ARMv7 architecture (this is the product: )
I already have a Realsense D435 and my project working on my linux machine and wanted to know if I can switch this to the odroid.

You can try to do that, but you’ll need to create the driver yourself (see the installation instructions for Odroid in the librealsense repository).


I got the realsense libraries installed and checked them with realssense-viewer.
Then I installed nuitrack-persee-ubuntu-arm32.deb and restarted my odroid, When I rebooted it and checked
echo $NUITRACK_HOME gave the correct address
but when I checked echo $LD_LIBRARY_PATH it gave me a blank,
so I tried to add it using
echo “export LD_LIBRARY_PATH=/usr/local/lib/nuitrack” >> /etc/profile.d/
I got bash: /etc/profile.d/ Permission denied
I tried to run it as sudo and got the same error,
So I deleted the file and created a newfile and added both. checked with echo and they were updated.
but when I tried to add the license using sudo -E nuitrack_license_tool, and run the compatibility test, the test gets completed without opening camera and the add license button is still not available

Current Nuitrack version doesn’t support RealSense API driver for ARMv7, however, there is support for OpenNI API drivers. So, you can try to build RealSense2 OpenNI2 driver following the instructions here. After you build the driver, copy and to usr/local/lib/nuitrack/OpenNI2/Drivers

@olga.kuzminykh I got the compatibility test to work and was able to add my license, but when I tried to run the ROS node, I got the error
/home/odroid/NuitrackSDK/Nuitrack/lib/linux64/ file not recognized: File format not recognized

since I was using an odroid so i replaced those files from linux_arm, after that I got

/home/odroid/NuitrackSDK/Nuitrack/lib/linux64/ undefined reference to `cv::Exception::Exception(int, std::string const&, std::string const&, std::string const&, int)’

I am not sure how to fix this. any ideas?

Please run the command:

export LD_LIBRARY_PATH=/usr/local/lib/nuitrack/