Sample Failed Exit Code: 3


Trying to test the latest Nuitrack, got the trial Lic, did the activation,

but after clicking -Test- I get a Sample failed. Exit code: 3

The test window opens and immediately closes without showing anything.

I have connected the cable to USB 3.0 Port and have also checked and updated all the 3.0 USB drivers,

The Intel Realsense Viewer Depth Sensor is working,

I’m on a Realsense L515, Windows 11, i7, GPU 3050,

Also, Check the following ScreenShot:

Please let me know,

Thanks in advance

Not 3.0

Wherever I connect the sensor to my device the intel realsense viewer shows me 2.1, Can you tell me how can I convert it to 3.0, I have tried connecting my USB cable to 3.0 port but still facing the same issue.

I’m on a Realsense L515, Windows 11, i7, GPU 3050,

Usb 3.0 is a requirement for realsense. Therefore, the sensor has a usb 3.0 connector. So the problem is either in the USB port of the PC or in the usb cable

  1. Make sure that you connect the sensor exactly to the USB 3.0 port
  2. Try another cable

Try it until USB “3.0” (3.1, 3.2) appears in Realsense Viewer

Can you suggest any sensor and USB 3.0 cables that work perfectly or any combinations, if so please share its link, I am still having the same issue Thank you.

L515, if it is not broken, and ALMOST ANY cable. This combination works well for me
Have you tried other cables?

Yes I have 2 USB 3.0 cables 1 which comes with L515 sensor and 2

hm…It looks fine. It’s strange why it doesn’t work. Maybe the USB port is the wrong version, check in the device manager.
If everything in this bundle (pc port+cable+sensor) is exactly USB 3.0, but Realsense Viewer shows USB 2.1, then try contacting Realsense support, they should advise something

Sure, ill try contacting Realsense support,

Do you have any other questions?

No i don’t have any other questions