[Solved] Can't find device error


#1

Hello,

I received the following error when I tried to run ./nuitrack_console_sample using my Intel RealSense 435 on my ubuntu 16.04 system:
UVCVideoCapture::open ERROR: can’t find device
Can’t find video camera!
Can’t find Depth camera!
Create DepthProvider: Realsense2DepthProvider

In addition, I am able to detect the sensor using the Intel RealSense Viewer:

I am currently using the Trial License and I am able to see testing results in the nuitrack_license_tool. I am wondering if I can run the ./nuitrack_console_sample using my Trial license or do I need to get the full license to be able to do it?

Thank you in advance for your help. I am looking forward to your response.
Best,
Andrew


#2

Hi Andrew,

The line Create DepthProvider: Realsense2DepthProvider indicates the successful start of a sample. If you can see the depth map when you run the Nuitrack activation tool, it means that Nuitrack works correctly.

nuitrack_console_sample shows how to use Nuitrack to get the user’s right hand position. The example covers the basic stages of Nuitrack API usage: initialization, module creation, callback registration, Nuitrack startup, data retrieval and resource release. The received data is written to the console (no GUI). To see the data in the console you have to stand up in front of a sensor at a distance of approximately 2 meters and move your hands.

Nuitrack Trial and Nuitrack Pro have the same functions, the only difference is time limit (each session with Nuitrack Trial lasts 3 minutes). You can purchase Nuitrack Pro to remove the time limit or use Nuitrack for commercial purposes.


#3

Hi Olga,

Thanks for your detailed explanation! I believe it is working now. I got panic after seeing the “can’t find device” messages.

Best,
Andrew