[SOLVED] Errors when first running Nuitrack on Ubuntu 16.04

The first time you try to launch Nuitrack, a message appears in the terminal

Please set NUITRACK_HOME variable (default value is /usr/etc/nuitrack)

Commands from GitHub don’t help:

echo “export NUITRACK_HOME=/usr/etc/nuitrack” > /etc/profile.d/nuitrack_env.sh

bash: /etc/profile.d/nuitrack_env.sh: Permission denied

It probably worked

echo 'export NUITRACK_HOME=/usr/etc/nuitrack' | sudo tee -a /etc/profile.d/nuitrack_env.sh
echo 'export LD_LIBRARY_PATH=/usr/local/lib/nuitrack' | sudo tee -a /etc/profile.d/nuitrack_env.sh
. /etc/profile.d/nuitrack_env.sh
1 Like

New error: when trying to run Test, an error is displayed in the activation utility

ERROR: Sample failed. Exit code: 127

What does this error mean?

When trying to run nuitrack_sample from the terminal:

nuitrack_sample: error while loading shared libraries: libglut.so.3: cannot open shared object file: No such file or directory

UPD: this and the first problem were solved by the command:

sudo apt-get install freeglut3