[Solved] Linux Installation


#1

I got the following error when i tried to install Nuitrack on my newly installed linux system(16.04).
Does anyone know how I could fix this?

$sudo dpkg -i nuitrack-ubuntu-amd64.deb
(Reading database … 325479 files and directories currently installed.)
Preparing to unpack nuitrack-ubuntu-amd64.deb …
Unpacking nuitrack (0.25.0) …
dpkg: error processing archive nuitrack-ubuntu-amd64.deb (–install):
trying to overwrite ‘/usr/bin/NiViewer’, which is also in package openni-utils 1.5.4.0-14
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
nuitrack-ubuntu-amd64.deb

I tried to remove oppeni-ultis incase that might help but was not able to other packages were dependent on it.
$ sudo dpkg -P openni-utils
dpkg: dependency problems prevent removal of openni-utils:
libopenni-sensor-pointclouds0 depends on openni-utils.

dpkg: error processing package openni-utils (–purge):
dependency problems - not removing
Errors were encountered while processing:
openni-utils


#2

Hi Pradeep,

Try to remove the openni-utils with the following command:

sudo apt-get remove openni-utils


#3

Hey Olga,

I got it installed, you can mark this closed.
thanks for your help.


#4

hey Olga,
Just a follow up question, I activated my license with
sudo -E nuitrack_license_tool.

Then I built the nuitrack_ni_gl_sample as explained in the readme. but when i launch the created application nothing happens.
$ ./nuitrack_ni_gl_sample
Press Esc to close window.
Can’t create depth generator with error: Can’t create any node of the requested type!

Am I missing something?


#5

What sensor do you use?


#6

I have an Intel Realsense D435


#7

nuitrack_ni_gl_sample doesn’t work with RealSense cameras as it works only with the sensors with OpenNI support.


#8

Oh I didn’t know that. Thanks for the information. Does any of the other examples work with D435?


#9

Yes, other samples should work fine, except for nuitrack_ni_sample (for the same reason).


#10

I tried other examples and all of them gave similar results:

./nuitrack_console_sample
Usage: nuitrack_console_sample [path/to/nuitrack.config]
UVCVideoCapture::open ERROR: can’t find device
Can’t find video camera!
Can’t find Depth camera!
ERROR: Can’t create DepthSensor module
AstraProPerseeDepthProvider: Can’t create RGB Stream (can’t open video capture)
KinectDepthProvider: Devices not found
OpenNI2DepthProvider: Can’t open device ( DeviceOpen using default: no devices found
)
OpenNIDepthProvider: Can’t create OpenNI DepthGenerator (OpenNI Status: Can’t create any node of the requested type!)
Realsense2DepthProvider: Can’t initialize Realsense2: rs2_config_resolve(config:0x1f30ac0, pipe:0x1f370a0):
Couldn’t resolve requests

terminate called after throwing an instance of ‘tdv::nuitrack::ModuleNotInitializedException’
what():
Aborted (core dumped)


#11

Do you connect your RealSense using USB 2.0 or 3.0? It’s important to connect it using USB 3.0.
Please provide us with 2 screenshots from realsense-viewer tool:

  1. Info tab
  2. Stereo Module > Resolution (list of modes)

#12

@olga.kuzminykh hey,

I was able to make the examples and work. Will post here with the results of my project once I am done. Thanks for your help.


#13

Hi, pillaya.
I have a error like you.
UVCVideoCapture::open ERROR: can’t find device
~

How did you solve the problem?