[Solved] Unable to complete license or test sample [Ubuntu 18.04]


I’m trying to use Nuitrack on an Intel Realsense D435 with Ubuntu 18.04 on an Intel NUC. Currently, I’m unable to complete the license with nuitrack_license_tool or run nuitrack_sample. When I run nuitrack_sample, I get the following message:

WARNING: Can not load library module: /usr/etc/nuitrack/middleware/libNuitrackModule.so
ERROR: Empty factory for DepthProvider
Empty factory for DepthProvider

When I run the compatibility check on the window that pops up after I run nuitrack_license_tool, an additional window pops up and takes the color of whatever is behind it and hangs until I close it. (The same window seems to appear when I call nuitrack_sample.)

I’ve followed the instructions (here), including installing libpng12-0. After installing and logging out (and restarting), my LD_LIBRARY_PATH variable was not set (NUITRACK_HOME was set), even though I export them in /etc/profile.d/nuitrack_env.sh as in step 4 of the install instructions.

To run nuitrack_sample or nuitrack_license_tool, I manually call . /etc/profile.d/nuitrack_env.sh. Then I get the error above. I’ve tried running sudo chmod -R 777 /dev/bus/usb/ (nothing changes in the error above) and realsense-viewer seems to work without errors.

How should I proceed?

Solved! There was a conflict for NiViewer with openni-utils'. I solved it by removingopenni-utils` with the following command:

sudo apt-get remove openni-utils

Then reinstalling Nuitrack

sudo dpkg -i nuitrack-ubuntu-amd64.deb
1 Like