[SOLVED] Unity 2021 crashes when Nuitrack.Init() is called

For my Unity 2D application I’m using skeleton tracking provided by Orbbec Astra Pro sensor. Implementation is based on nuitrack.net.dll library provided by Nuitrack for C#.

When Nuitrack.Init() is called, everything works fine for Unity 2018.3.0f2 but not for Unity 2021.2.1f1. Unity Editor crashes and I cannot get any info why this is happening. Try/catch block is not helpful but neither the Unity log files.

I’ve tried with Nuitrack v0.35.12, but I have the same problem.

Hello @ResDev
Are you using our NuitrackSDK.unitypackage?

Hello @Stepan.Reuk,

No. I’m using nuitrack.net.dll library provided by Nuitrack for C#. It works for app implemented in Unity 2018 as I mentioned.

I would try with the package but it would require bigger changes to my current project.

Hm… I tried to copy nuitrack.net.dll from a package to an empty project and everything seems to work. Try running this project https://disk.yandex.ru/d/N1xwuVaiTO0ysA

I’ve tried it with nutirack v0.35.12, and have same problem. Unity crashes on line nuitrack.Nuitrack.Init();

The easiest way to identify the problem. Try creating a project for this version of Unity, import NuitrackSDK.unitypackage and run the AllModulesScene scene.

(Maybe it’s problem with tbb.dll https://github.com/3DiVi/nuitrack-sdk/blob/master/doc/Troubleshooting.md#unity)

1 Like

It was problem with tbb.dll.
Now it works fine.

Thank you.

1 Like