[Solved] UserTracker::create issues access violation (0xc0000005)

Hi all,

I am migrating NUITRACK SDK from v1.4.0 to v1.4.1.
I face to access violation issue on UserTracker::create.
It’s occurred on UserTracker.h:86, but it’s not occurred on v1.4.0.
I tried this method using sample code (nuitrack_gl_sample), and result is same.

My development environment is,

  • OS : Windows 10 Pro (Ver.1903)
  • IDE : Visual Studio 2019 (16.2.3)
  • Language : C++
  • Sensor : RealSense D415 (FW :
  • Nuitrack : 0.29.0
  • Nuitrack SDK : 1.4.1

Anyone knows how to resolve this issue ?

Best regards,

Hi all,

Excuse me, it’s caused by NUITRACK installer failure.
v0.29.0 installer issued error on icacls command with error code 87, but I ignored its issue.
Now, I grant login user to access to NUITRACK data directory using command prompt, and SDK works fine !

However, why error code 87 is occurred on installation ?

Thank you and best regards,

Hi Shigeyasu,

This error occurs if there’s a space in a username. Please check out this thread: Unable to enter License Activation Key

Hi Olga,

Indeed, my user name is included space.
On installation error, I had used “icacls” command from command prompt as administrator.
Anyway, it works fine now !

Thank you for your cooperation,