Unable to enter License Activation Key


#1

Hello,

I’m attempting to enter a license key in the Nuitrack Activation Tool located here:
~PATH\Nuitrack\nuitrack\nuitrack\activation_tool

However the the “Enter Activation Key” remains grayed out even after successfully running the Compatibility Test.

I’m using version 0.28.0 of the Activation Tool program.

Does anyone have any recommendations on how to enter a license key?

Thank you.


[Solved] UserTracker::create issues access violation (0xc0000005)
#2

Hi Daniel,

Please run nuitrack_sample and provide us with the output.


#3

Hi everyone,

I have the same issue as Daniel. The nuitrack_sample work perfectly and the compatibilty test too ! I sent a request to the Nuitrack support, I let you know if I’ll get an answer !


#4

Hello olga and lucie,

I ran the nuitrack_sample and I can confirm that it runs normally where I can see black and white depth data. It times out after 3 seconds with the message “Please get a license at nuitrack.com”.

Even after running the nuitrack_sample, I am still unable to enter my activation key when running the activation tool.


#5

Some additional clues:

I uninstalled Nuitrack and attempted to reinstall it once again. I received the following error during the install process:

Error during installation process (com.3divi.nuitrack):
Execution failed (Unexpected exit code: 87): "cmd/C icacls C:\Program Files\Nuitrack\nuitrack\data /grant %USERNAME%:F /T"

I’m able to ignore this error and the install completes. However, I’m not sure if this is something contributing to the license activation error.


#6

Hi Daniel,

You have to run Nuitrack activation tool to activate the license. The message “Please get a license at nuitrack.com” means that the license wasn’t activated.
Please run the following command in the Windows PowerShell:
$Env:USERNAME


#7

Hello Olga,

Thank you for the reply. I ran the command in powershell and I can see my username. Is there something I should check with my username?

And yes, I’m attempting to activate the license. But I’m still unable to enter the key due to the entry field being locked.


#8
  1. Please run nuitrack_sample from Windows PowerShell and provide us with the console output.
  2. Check that USERNAME has read/write permissions to the folder <NUITRACK_HOME>/data
  3. For some reason the path to <NUITRACK_HOME>/data shown during the installation is incorrect in your case. It should be C:\Program Files\Nuitrack\nuitrack\nuitrack\data instead of C:\Program Files\Nuitrack\nuitrack\data.

You can try to run the following command from the Windows PowerShell as Admin (Win+X):

cmd /C icacls "C:\\Program Files\\Nuitrack\\nuitrack\\nuitrack\\data" /grant %USERNAME%:F /T


#9

Hello Olga,

Thank you for you reply, it has helped me find the solution!

1.) The output from the nuitrack_sample only showed this:
Create DepthProvider: OpenNI2DepthProvider

2.) I did some initial checking and my user did not have write permission. I enabled write access to the /data folder but the same problems persisted.

3.) This is strange. My actual /data folder is located in C:\Program Files\Nuitrack\nuitrack\nuitrack\data. However I’m not sure why the install is trying to access a data folder in C:\Program Files\Nuitrack\nuitrack\data.

However when I ran the icacls command, I do see an error about invalid arguments.

I turns out, the problem was with my machine’s username. There was a space in the username causing the issue (e.g. “USERNAME 3”). Using netplwiz, I modified my username to remove the space, restarted, and ran the activation tool again. The field now allows me to enter my activation key.

Thank you!


#10

Hello,

My OS is Linux and the problem was because of the permission of the data folder. With Linux, the data folder is in /usr/etc/nuitrack
So I run the following command to change the permission :
sudo chown -R $USER:$USER data/
And it worked for me !

Thank you


#11

I am also having the same problem - the activation box remains greyed out, and I am unable to enter the activation key. On windows 10 64 bit:

  1. I installed nuitrack
  2. I ran the activation tool
  3. the compatibility check passed
  4. the activation box remains greyed out.

I also tried the 32 bit installer. Same result.

I also tried running the command below:

cmd /C icacls "C:\\Program Files\\Nuitrack\\nuitrack\\nuitrack\\data" /grant %USERNAME%:F /T

Still doesn’t work.


#12

Ok. I solved the problem by right clicking on the activation tool and running as administrator.

Come on guys, this is a pretty mediocre installation experience for commercial software. I’d suggest:

  1. investing in the couple hundred bucks it costs to get the installer signed.
  2. Fixing the activation tool so that it doesn’t need admin privileges.
  3. Serving a proper download site, rather than the default apache index…

I’m sure there is higher priority work to be done, but gosh, just getting this installed is painful.


#13

Hi dmacairbag,

Sorry for the issues you’ve encountered and thanks for your feedback! We’ll take your comments into account.
However, the activation tool doesn’t need admin privileges, that’s strange that it had to be run as Administrator in your case.


#14

Also having the same problem here. I’ve tried every possible solution and still not working, also run it under admin. Is there any other solutions?


#15

Hi Tony,

  • What is your Nuitrack version? It’s displayed at the bottom of the activation tool window.
  • Do you see the depth map after you click “Compatibility Test”? Is the test completed?
  • Please run nuitrack_sample and provide us with the output.
  • Try to run the command: cmd /C icacls "C:\\Program Files\\Nuitrack\\nuitrack\\nuitrack\\data" /grant %USERNAME%:F /T

#16

So I solved the problem by manually open the write access of the data folder。
Thanks for the quick reply. :slight_smile:


#17

Agreed! I had to manually disable Windows Firewall to complete the download of the unsigned exe. Not a pleasant experience.