The error: the game object does not exist in current context

the error occured : gameobejct is does not exist in the current context
I’m trying Nuitrack SDK with realsense D435, but I didn’t connect realsense to PC
so, dose the error occured by disconnecting realsense? or other reason?
please answer

Hi parksungju,

Actually, it seems that this issue is not connected to Nuitrack of connection/disconnection of a camera. Usually, this issue occurs if you’re trying to do some actions with an object but forgot to assign it in Editor (drag-and-drop it to the necessary field).

I also had the error “game object” does not exist. "
I downloaded the latest version of the nuitrack package, and the error occurs out of the box.
It seems to be a problem in ExperimentalRecorder.cs in lines 20-21.

Commenting on these two lines solved the problem for me.
Perhaps, this error appears only in version 2018.2+ Unity.

Thank you very much I have not tried reinstall above 2018.2+ version, I will try this. And I solved this problem
public ExperimentalRecorder(GameObject rootObject)
fixed : rootObject -> gameObject

1 Like