Ubuntu installtion


#1

when I run the install using
sudo dpkg -i .deb

I get the following output

(Reading database … 213961 files and directories currently installed.)
Preparing to unpack nuitrack-ubuntu-amd64.deb …
Unpacking nuitrack (0.28.0) over (0.28.0) …
Setting up nuitrack (0.28.0) …
==============================================
Nuitrack installation script
logname: no login name
adduser: The group `video’ already exists.
logname: no login name
chown: missing operand after ‘/usr/etc/nuitrack/data’
Try ‘chown --help’ for more information.
All done
==============================================
**and when I continue to install, I am not able to activate with **
**sudo -E nuitrack_license_tool **
**I get: **
please run as current user


Ubuntu and Intel RealSense D415 issues
#2

Hi Pradeep,

It seems that your login name is empty. Please run the command:

echo $(logname).

To finish the installation, run the following command (from sudo):

chown -R $(logname) /usr/etc/nuitrack/data

where $(logname) is your user name (see the first command).

To run nuitrack_license_tool, enter the command “nuitrack_license_tool” (without quotes) as a current user (with no sudo).


#3

Hi Olga,

when I tried echo $(logname)
logname: no login name, so I tried with echo $USER
and used that in chown -R $USER /usr/etc/nuitrack/data
when I tried to install the license with nuitrack_license_tool, the compatibility test just returns “Test completed!” without opening the camera frame. and I am still unable to activate the license.


#4
  1. Please run the following command and provide us with the console output:

    ldd /usr/etc/nuitrack/middleware/libNuitrackModule.so | grep not

  2. Run nuitrack_sample and provide us with the console output.


#5
  1. libcurl.so => not found
  2. Empty factory for DepthProvider.

#6

Please run the following command to install the missing package:

sudo apt-get install libcurl4-openssl-dev


#7

I installed libcur14 and tried the nuitrack_sample again I got the following console output:

UVCVideoCapture::open ERROR: can’t find device
Can’t find video camera!
Can’t find Depth camera!
Create DepthProvider: Realsense2DepthProvider
Inconsistency detected by ld.so: dl-close.c: 811: _dl_close: Assertion `map->l_init_called’ failed!

I tried the license to tool and the camera frame opened for a few seconds and crashed and gave me test completed, but I was still not able to enter the key.
I also got a crash report:


#8

Do you see the file "e24b..." in the folder /usr/etc/nuitrack/data/?
If yes, close the Nuitrack activation tool, run it again, complete the test and activate the license.


#9

I didnt find the e24b folder but, I got the licensing tool to work.
I ported my project from another PC that used Nuitrack ROS package and when I tried to use the ROS packed I got “Segmentation Fault (core dumped)”. Any idea on if the ROS package for Nuitrack is still working?


#10

Did you try to run our standard samples? Do they work?


#11

Yes both nuitrack_c11_sample and nuitrack_sample work.